Please help in anayzing system hang

Please help in anayzing system hang

Post by Samee » Fri, 09 Dec 2005 02:09:50


Hi,

I am loading my driver on Windows XP professional with SP1. While
loading fresh it loads perfectly, but on restart machine hangs. After
analyzing I have got following stack details. Can any one please
explain me what exactly could be the problem.

*******************************************************************************
*
*
* Bugcheck Analysis
*
*
*
*******************************************************************************

Unknown bugcheck code (0)
Unknown bugcheck description
Arguments:
Arg1: 00000000
Arg2: 00000000
Arg3: 00000000
Arg4: 00000000

Debugging Details:
------------------


DEFAULT_BUCKET_ID: DRIVER_FAULT

BUGCHECK_STR: 0x0

LAST_CONTROL_TRANSFER: from 805120f8 to 805103fa

STACK_TEXT:
fa3337b8 805120f8 00000001 01dff110 00000030
nt!RtlpBreakWithStatusInstruction
fa3337b8 806ccf7f 00000001 01dff110 00000030
nt!KeUpdateSystemTime+0x142
fa33383c 804eb91d 01001010 0000003b fa333850
hal!HalBeginSystemInterrupt+0x83
fa33383c 804f1ae1 01001010 0000003b fa333850 nt!KiChainedDispatch+0x1b
fa3338c8 806cd1f2 00000000 00000000 00000000 nt!KiDispatchInterrupt
fa3338c8 804ea504 00000000 00000000 00000000
hal!HalpDispatchInterrupt2ndEntry+0x1b
fa333c28 80587bda 80e19da8 8057c706 f9d99600
nt!KiInitializeContextThread+0x196
fa333c70 8058780f 80e19da8 00000000 8057c706 nt!KeInitThread+0x13b
fa333d4c 8057c77c fa333db4 001f03ff 00000000 nt!PspCreateThread+0x23a
fa333d80 f9d99651 fa333db4 001f03ff 00000000
nt!PsCreateSystemThread+0x31
fa333dac 8057c73a 00000378 00000000 00000000 NDIS!ndisWorkerThread+0x49
fa333ddc 805124c1 f9d99600 00000000 00000000
nt!PspSystemThreadStartup+0x34
00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x16


FOLLOWUP_IP:
NDIS!ndisWorkerThread+49
f9d99651 85c0 test eax,eax

FOLLOWUP_NAME: MachineOwner

SYMBOL_NAME: NDIS!ndisWorkerThread+49

MODULE_NAME: NDIS

IMAGE_NAME: NDIS.sys

DEBUG_FLR_IMAGE_TIMESTAMP: 3d6de4c3

STACK_COMMAND: kb

BUCKET_ID: 0x0_NDIS!ndisWorkerThread+49

Followup: MachineOwner
=============================================================

I guess this is probably my drivers interrupt routine. But I am not
able to figure out why it is making system halt.

Please help, this is urgent for me.

Thanks in advance,

Sameer