Target Analyzer Probe cannot find Intel PRO Wireless 2200bg mini-PCI card

Target Analyzer Probe cannot find Intel PRO Wireless 2200bg mini-PCI card

Post by andreenti » Mon, 23 Feb 2009 02:43:07


Hi!

First of all I have to say that I am totally new to Windows XP
Embedded.

So far I have my image up and running with the Explorer Shell and all
needed components so far.

However I have now run into some problems. My divice was initialy
running XP Home. I have run the tap.exe on the target, made an SLD
from the .pqm and so on... Everything seems to work fine, except for
the Intel PRO/Wireless 2200bg mini-PCI adapter not being recognized by
tap.exe.

When I boot into my runtime image and open the device manager, there
are 3 devices marked with a "!". One is my network adapter (not the
wireless one), an uknown device and the display adapter (which was
also not recognized by tap). What the unknown device is, I don't know,
but it doesn't seem to be the wireless adapter, since it won't accept
the appropriate drivers.

For the wireless to work I have added the following components, as
described on MSDN:

Primitive: Wzcsvc
Network Provisioning Service
Wireless Zero Configuration
TCP/IP Networking with Filesharing

Are there components I forgot to add?

Thank you in advance!
 
 
 

Target Analyzer Probe cannot find Intel PRO Wireless 2200bg mini-PCI card

Post by MV » Mon, 23 Feb 2009 04:12:56


You might have to create a driver component for the adapter. Or just install
the driver.

--
Regards,

Sean Liming
www.sjjmicro.com / www.seanliming.com
Book Author - XP Embedded Advanced, XP Embedded Supplemental Toolkit

 
 
 

Target Analyzer Probe cannot find Intel PRO Wireless 2200bg mini-PCI card

Post by andreenti » Mon, 23 Feb 2009 06:14:41

I have just installed the driver for the card, which I know works fine
in XP Pro. The device manager didn't want it so I had to "force" the
installation with an executable provided with the driver. Now the
system recognized the card correctly and even, for some reason,
installed the ethernet card. While the ethernet adapter is fine, the
PRO Wireless is marked with a yellow "!". Again, I know it is the
right driver for XP Pro.

As of now I suddenly experience another issue. Booting into the system
takes decades since I have added the above mentioned components to my
image. Let me try to describe. I have added Automatic Logon, where I
must have missed something because it sais that I cannot be logged in
and I have to type in "Administrator" to get in. During boot I get
this white striped loading bar before the actual XP Professional logo
(without "Embedded" for some reason) which also takes approx. a minute
or so to load, from then it takes several minutes until the logon
screen, from which it is another minute until I can do something. As
far as I know, such problems accur when something is wrong with the
networking in Windows.

Somehow I suspect the problems are interrelated. Btw as the location
of the "unknown device" mentioned earlier it is said to be "on ALi PCI
to ISA bridge". Since the Intel PRO/Wireless is a mini-PCI adapter I
asume it has smth to do with the functionality of the card.

Btw creating the driver component fails for some reason. It sais the
files were not found although I have added a package and pointed to
the right repository.... But that's another issue.

Maybe the problem is, that from all componets found by the tap I am
not sure which could be software enumerated devices I do not need (or
smth like that) and which could slow down the overall performance.
Since tap didn't find the wireless and the grafics card, who knows
what else it could have found/not found?

I'm kinda stuck here. Any help will be greatly appreciated.

Thanx in advance!
 
 
 

Target Analyzer Probe cannot find Intel PRO Wireless 2200bg mini-PCI card

Post by MV » Mon, 23 Feb 2009 09:43:56


How did you run TAP.EXE? On XP Pro?

Here are a couple of videos on importing device drivers to create
components:

http://www.yqcomputer.com/
http://www.yqcomputer.com/

Regards,

Sean Liming
www.sjjmicro.com / www.seanliming.com
Book Author - XP Embedded Advanced, XP Embedded Supplemental Toolkit
 
 
 

Target Analyzer Probe cannot find Intel PRO Wireless 2200bg mini-PCI card

Post by andreenti » Mon, 23 Feb 2009 20:30:19

Thanx for the links! I'll definetly check them out to find out what I
did wrong.

And yes, I ran tap.exe on XP Pro. I still have that HDD as an
insurance. I'm playing around with another HDD.
 
 
 

Target Analyzer Probe cannot find Intel PRO Wireless 2200bg mini-PCI card

Post by andreenti » Mon, 23 Feb 2009 20:38:46

Oh forgot smth.

Did I get the basics right regarding components for the wireless
connection to work? I am building the image for the device basicaly to
become a MID or maybe a little more than that.

The long boot up however concerns me. Can you say something about that?
 
 
 

Target Analyzer Probe cannot find Intel PRO Wireless 2200bg mini-PCI card

Post by andreenti » Wed, 25 Feb 2009 06:54:18

Solved... Thx for the video links!