Monitor shown unknown device in device manager

Monitor shown unknown device in device manager

Post by jetq8 » Sat, 10 Mar 2007 00:03:45


hello, everyone,

I have a working xp embedded image in our device which works either
with or without keyboard/mouse/monitor, it works fine either way, but
I noticed that there is no "Monitor" in device manager, it's shown as
unknown device with a questionmark. how do I change registry to make
it recognize monitor but still work when there is no monitor
connected?

thanks
 
 
 

Monitor shown unknown device in device manager

Post by KM » Sat, 10 Mar 2007 04:15:58

You'd probably need to install (or componentize and include in the image at the first place) the hardware specific Monitor driver.

--
=========
Regards,
KM

 
 
 

Monitor shown unknown device in device manager

Post by jetq8 » Sat, 10 Mar 2007 23:33:40

hi, KM,

this image has "headless component"(can't remember the exact name of
that component), without this component, the monitor will show up in
device manager and the monitor will show up as standard monitor,
"headless component" was added becasue this unit works half of time
without monitor and keyboard, it still work but monitor will show up
as unknown device. is there any way to let XP embedded to detect
monitor and show up as standard monitor instead of unknown device, as
well as work without monitor.

jet
 
 
 

Monitor shown unknown device in device manager

Post by KM » Sun, 11 Mar 2007 03:41:54

You are probably referring to VGA Headless support component?
Well, you may not need to include it since you don't really remove the video card from the target, do you? In other words, you
target is going to be run without monitor attached but it wouldn't be a truly headless mode, just no output console attached.

--
=========
Regards,
KM
 
 
 

Monitor shown unknown device in device manager

Post by jetq8 » Sun, 11 Mar 2007 06:57:28


right KM, I should not put that component in at first place, is there
any way to turn headless off through registry without redo the whole
image?

============
Regards,
Jet
 
 
 

Monitor shown unknown device in device manager

Post by KM » Sun, 11 Mar 2007 15:52:12

Jet,


You said you got your actual monitor driver installed on th image, right? If so, it is probaly just conflicting the the virtual
display driver. Try removing tsddd.dll from windows\system32 folder from the target device a, reboot and see if your monitor driver
starts working properly (basically you will "kill" the headless vga driver this way).

I'd still do that by clean way of re-FBA'ing the entire image.


--
=========
Regards,
KM