Won't recognize CDs in one drive - won't recognize DVDs or CDs in other drive.

Won't recognize CDs in one drive - won't recognize DVDs or CDs in other drive.

Post by randwil » Fri, 07 Sep 2007 05:09:58


I have two DVD-R drives, a Plextor PX-708A (E-Drive) and a Sony Dual RW
Drive (F-Drive).

Both worked great until this week. Now the Plextor will read DVDs but not
CDs, music or data.

The Sony will not read anything.

Errors I get from either drive with either type of media, "Windows Media
Player encountered a problem while playing this file." or "Request cannot be
performed because of an 0/0 device error." or 'Disc not formatted. Disc
might be corrupted or using a format not compatible...blah blah." or I get
an hourglass for minutes while nothing happens.

I would like for both drives to read and write CDs and DVDs again. How can
I fix this?

Thank you.
 
 
 

Won't recognize CDs in one drive - won't recognize DVDs or CDs in other drive.

Post by Rich Barr » Fri, 07 Sep 2007 06:03:22


Try dougknox's fix. www.dougknox.com Rt Column about 11 down.
Restore Cd/Dvd drives to Explorer. You could also try rt clicking
MyComputer>
select Properties>Hardware>Device Manager>your Dvd drives. rt click each
one
and choose Uninstall. Restart and let XP reinstall them.

 
 
 

Won't recognize CDs in one drive - won't recognize DVDs or CDs in other drive.

Post by randwil » Fri, 07 Sep 2007 06:46:53


Thanks. I did both of your suggested options but there is no change in the
behavior.

To be clear, both drives show up in the list of drives in the My Computer
window, so the system recognizes them to be there, just not most of the
media placed into them.
 
 
 

Won't recognize CDs in one drive - won't recognize DVDs or CDs in other drive.

Post by Rich Barr » Fri, 07 Sep 2007 07:57:55


Could you try disconnecting one, then the other. Just remove the Molex
Power connector.
 
 
 

Won't recognize CDs in one drive - won't recognize DVDs or CDs in other drive.

Post by randwil » Fri, 07 Sep 2007 09:09:34


To be clear, do you mean I should power down, disconnect one player then
turn the computer back on and see if the remaining powered player now works?
Then do the same thing with the other player?
 
 
 

Won't recognize CDs in one drive - won't recognize DVDs or CDs in other drive.

Post by Rich Barr » Sat, 08 Sep 2007 06:24:15


Yes, that's correct.
 
 
 

Won't recognize CDs in one drive - won't recognize DVDs or CDs in other drive.

Post by randwil » Sat, 08 Sep 2007 08:19:25


Okay, When I disconnect power to the Sony (Drive F) and try to play anything
in the Plextor (Drive E) I now get nothing out of the Plextor. Just -
"Please insert a disc into Drive E." Also it will not eject a disc when I
right click and go to Eject.

When I disconnect power to the Plextor, and hook power to the Sony, it now
plays DVDs and CDs (music and data) just fine.

So I surmise that the Plextor drive is bad.

So...

I stick in an old QPS CD drive (that works) in place of the Plextor (in the
Master, "E", position on the ribbon and power cords). Strangely, when I
look in My Computer I now have a "CD Drive (H:)" listed IN ADDITION TO the
Sony (F), which you'd expect because it's still there and hooked up, but
also there is "Plextor DVD (E:)"! Arrgh! There is NO, I repeat NO Plextor
drive hooked to the computer.

When I put an audio CD in the old QPS CD drive now hooked up at the at the
"E" position, it shows up in the "F" position and plays. Right-clicking and
choosing Eject from the "F" listing in My Computer causes the disc to Eject
from the QPS.

When I put a music CD into the Sony, which is still in the "F" position, it
shows up in the "E" position in My Computer. When I tell it to "Play audio
CD using Windows Media Player" WMP launches and gives the error - "Windows
Media Player encountered a problem while playing the file."

I surmise that I've got to get that Plextor info out of the computer's
memory because that's causing these screw-ups. BUT, there is no Plextor DVD
drive listed in Device Manager for me to delete.

I will eventually put a new drive in "E" position to replace the Plextor
(I'll leave the old QPS CD player in place until I get it). But as long as
Windows thinks that the Plextor is still in the "E" position, the Sony won't
work. And I'll still have that problem when I put a new DVD drive in "E"
position.

How do I get rid of any and all remnants that the dead Plextor drive is or
ever was hooked into my system?
 
 
 

Won't recognize CDs in one drive - won't recognize DVDs or CDs in other drive.

Post by Fran » Sat, 08 Sep 2007 14:44:23


When one removes a device it should be uninstalled from device manager then
removed.
Nero has a toolkit and so does Plextor.
CD/DVD drives are also very specific about what type of media they will
read.

Good Luck
 
 
 

Won't recognize CDs in one drive - won't recognize DVDs or CDs in other drive.

Post by randwil » Sun, 09 Sep 2007 00:45:34


Thanks.

I re-hooked up the Plextor then went to Device Manager and removed it. I
then disconnected it. On reboot it is STILL listed in My Computer in the
"E" position.

"Plextor Toolkit" yields no hits on Google. "Toolkit" search at Plextor.com
yields irrelevant results.

Nero Toolkit is described as; "Nero ToolKit is the industry standard for
testing and benchmarking optical recording drives." This would NOT seem to
be a tool for removing an erroneous entry in a Windows XP system.

So, I ask again, does anybody know how to remove the drive listing from My
Computer or do I have to do a complete re-install of WindowsXP?
 
 
 

Won't recognize CDs in one drive - won't recognize DVDs or CDs in other drive.

Post by Fran » Sun, 09 Sep 2007 05:40:49


That doesn't sound right. I know that because of WPA windows never forgets
any installed hardware. Why it is *** on to the drive letter is strange
to me.
I hope someone will chime in that knows more.
 
 
 

Won't recognize CDs in one drive - won't recognize DVDs or CDs in other drive.

Post by randwil » Sun, 09 Sep 2007 07:25:27

Since no one seems to be able to tell me how to fix this I did an experiment
on my own.

I booted into Safe Mode. And hey, the Plextor (E:) didn't show up in "My
Computer".

So I went to Disk Management and reassigned my storage HD (which was "G") to
"E".

But when I rebooted into regular mode nothing had changed. The erroneous
Plextor drive still had the "E" and the storage HD was back to "G" when I
looked in "My Computer"..

I mention this in hopes that the fact that the erroneous drive doesn't show
up in "My Computer" will give some knowledgeable person a clue as to how to
help me fix this problem.
 
 
 

Won't recognize CDs in one drive - won't recognize DVDs or CDs in other drive.

Post by Fran » Sun, 16 Sep 2007 21:14:31


I have, for years, assigned (R) to the read only drives and (S) to the RW
drives.
This may require a chnge in the registry.
http://www.yqcomputer.com/
Try it to see if it will work for you. It should free up the high letters
for you. To me
this letter scheme from Microsoft is a nightmare.