Please help with problem using tkcvs (winXP, Cygwin)

Please help with problem using tkcvs (winXP, Cygwin)

Post by maggiezhan » Thu, 08 Jan 2004 02:24:43


ello,

I am experiencing problems trying to set up tkcvs under windows xp.
Could someone please help? Thanks in advance...

My case is quite complex, as least as I can see... The server is a
Linux box, while I am working on WindowsXP.

1. Originally, someone helped me set up WinCVS through ssh under
Cygwin.

The procedure started with "ssh-keygen -t rsa" and then upload the
identity.pub file to the Linux server, etc. It works fine. And I can
also use cvs command line under Cygwin with no problem. But I feel
WinCVS is not as good as tkcvs which I had a little bit experience
under Linux.

2. Then we tried to install tkcvs under windows. It worked for my
friend----tkcvs simply picked up all the setup he had. But it is a
nightmare for me:

1) I had a full installation of Cygwin, so I tried to install tkcvs
(version 7.1.4) using the tk/tcl that comes with Cygwin, but it didn't
work. Fortunately, switching to "wish" succeeded in installation. But
tkcvs still didn't work for me ---- it kept giving me 'child process
exits abnormally" errors, and nothing useful showed.

2) Then I installed a windows tcl version 8.4.5, and reinstalled
tkcvs with a newer version 7.2. It still doesn't work for me: either
on my sandbox previously checked out using WinCVS, or trying to
checkout a new sandbox. The trace messeages are even different if I
execute tkcvs from "file manager" or use Cygwin command line.

i) If I double click tkcvs.tcl from "file manager", I got the
following trace:


--------------------------------------------------------------------------------------------------------------
[::exec::0::run_exec] cvs -n -q status -l
[::exec::0::err_handler] rsh.exe: can't establish connection

> IP_ADDRESS:Connection refused

[::exec::0::out_handler] Close Failed - errorCode CHILDSTATUS 2100
1
[::exec::0::out_handler] ExecDone 1 {child process exited
abnormally} {CHILDSTATUS 21001}
[::exec::1::run_exec] cvs -n -q editors -l
[::exec::1::err_handler] rsh.exe: can't establish connection

> IP_ADDRESS:Connection refused

[::exec::1::err_handler] rsh.exe: can't establish connection

> IP_ADDRESS:Connection refused
cvs [editors aborted]: end of file from server (consult above
messages if any)

[::exec::1::out_handler] Close Failed - errorCode CHILDSTATUS 988 1
[::exec::1::out_handler] ExecDone 1 {child process exited
abnormally} {CHILDSTATUS 988 1}
[read_cvs_dir] OPEN CVS/Repository
[read_cvs_dir] OPEN CVS/Root
[::exec::2::run_exec] cvs -d :ext:USER_NAME@IP_ADDRESS:/home/cvs-rep
checkout -p
CVSROOT/modules
[::exec::2::err_handler] rsh.exe: can't establish connection

--------------------------------------------------------------------------------------------------------------

ii) if I execute tkcvs from Cygwin command line, I got the following
trace:

--------------------------------------------------------------------------------------------------------------
[::exec::0::run_exec] cvs -n -q status -l
[::exec::0::err_handler] cvs [status aborted]: end of file from
server (consult above messages if any)

[::exec::0::out_handler] Close Failed - errorCode CHILDSTATUS -1 1
[::exec::0::out_handler] ExecDone 1 {child process exited
abnormally} {CHILDSTATUS -1 1}
[::exec::1::run_exec] cvs -n -q editors -l
[::exec::1::err_handler] cvs [editors aborted]: end of file from
server (consult above messages if any)

[::e
 
 
 

1. problem with cronjob run on Cygwin, Cygwin is running on WinXP

2. cron job under Cygwin, Cygwin runs on WinXP

Hi everyone,

Don't know if it is the right place to post, please kindly direct me
to the right group if it is not proper here.

I intend to run a cron job on Cygwin. The Cygwin runs on WinXP.

I checked the Windows service list and found cron service is started.

I use "crontab -e" to set up the following task,

30 * * * * /cygwin/d/expect scriptname.exp

I checked "crontab -l". It shows:

# DO NOT EDIT THIS FILE - edit the master and reinstall.
# (/tmp/crontab.5352 installed on Mon Mar 26 12:21:31 2007)
# (Cron version -- $Id: crontab.c,v 1.8 2004/12/21 16:14:41 corinna
Exp $)
30 * * * * /cygwin/d/expect scriptname.exp

I suspect it is the priviledge problem, so I type "crontab -u {myWinXP
login ID} -e" and it shows:

must be privileged to use -u

Anyone knows that is the problem? Thanks in advance.

3. Help: Fail to build ACE with Cygwin+MinGW on WinXP

4. Sysprep problem with WinXP - Please Help!!!

5. Please URGENT HELP required - WinXP Problem

6. WinXP Problem, Please Help!

7. Curb installation problem on WinXp. Please Help

8. WinXP Problem, Please Help!!!

9. WinXP clean installation problem (Please Help!)

10. Problems connecting to winxp printer from win2000 machine - help please

11. Anyone has ever used "cygwin" please get in

12. Compiling 2.5.5 with cygwin, Was : Problems for compiling 2.5.4 branch with cygwin

13. memory problem with cygwin/gfortran and cygwin/g77

14. Compiling 2.5.5 with cygwin, Was : Problems for compiling 2.5.4 branch with cygwin

15. Problem under Cygwin after Cygwin update