I think this solution is less readable and is one step further away from deciphering.
Someone comes across the variable 'theItems' and looks at its definition to see what it is and finds
it is of type 'items'!
Then you have to find where 'items' is defined.
If it is on the previous line then it is easy enough, but not as easy as just seeing that it is of
I agree that ultimately std::vector is the most readable, but I wouldn't call it laziness to use
'using namespace std' or 'using std::vector'.
For a start it is a minor insult to anyone who chooses to use it, automatically getting them
offside, and I don't believe is valid as an argument as it has no bearing on whether the code it is
effective or not.
One may say that using the lift is lazy compared to using the stairs, but the lift is more
convenient, especially if you are in a hurry.
Ultimately you may get a heart attack by using the lift too much, but then again, maybe it gives you
more time for those ultimate sports.