ENVI on Fedora Core 9 in VMware virtual machine

ENVI on Fedora Core 9 in VMware virtual machine

Post by jdehl » Wed, 10 Sep 2008 04:24:16


Hello, I have recently configured a VMware virtual machine with Fedora
Core 9. I installed IDL and ENVI without any errors. I can start IDL
and contact the license server. When I try to do anything graphical, I
get a segmentation fault. This includes launching ENVI. I can launch
idlde and start the IDL workbench. Typing tv, dist(200) gets me a
Fatal error.

I am not sure if my problem relates to Fedora Core 9, or the fact that
I am running under a virtual machine. The only tech tips on ittvis.com
that come up are old and relate to FC 6. Does anyone have ENVI running
successfully under either or both of these?

John Dehls
 
 
 

ENVI on Fedora Core 9 in VMware virtual machine

Post by RussellGre » Wed, 10 Sep 2008 09:23:57

Which version of IDL?

There is a known seg. fault problem with IDL6.* and linux.

Assuming, this is the problem, you should be able to do a simple plot
to screen like

x = findgen(100) / 10.
plot, x, sin(x)

But if you get *tricky* and try

xloadct

The sky falls down.

Is this the situation?

 
 
 

ENVI on Fedora Core 9 in VMware virtual machine

Post by RussellGre » Wed, 10 Sep 2008 12:04:42

Alternatively, if its IDL7.? you may need to install libstdc++.so.5
within Fedora.

There have been posts here on this problem before.

Hope I have helped.
 
 
 

ENVI on Fedora Core 9 in VMware virtual machine

Post by jdehl » Thu, 11 Sep 2008 00:26:06

I am running IDL 7/ENVI 4.5. Even the simple stuff crashes IDL. I
installed libstdc++.so.5 (and various other libraries mentioned in
tech tips) with no improvement.

I have solved the problem for now by creating a new VM with Fedora
Core 6 running. Envi works just fine and I have no need for a newer
version of Fedora. I simply started with FC9 since it was the latest.
FC6 has always been stable for me.

Anyway, at least I now know it was not a problem with VMware. Thanks
for your help all.