using knoppix to restore lilo <== found workaround

using knoppix to restore lilo <== found workaround

Post by Hognoxiou » Sat, 14 Feb 2004 23:19:09



...

I was running from a virtual terminal anyway. Perhaps Knoppix is out of
synch with Red Hat 7.1 (which is pretty old) - for example Knoppix lilo has
options missing from the old one.

Anyway, found a workaround (not quite a solution) which I'll add to assist
anyone else has a similar problem:

Boot from the original RH install disk 1.
Choose the language, keyboard & mouse.
Choose upgrade, choose customise which packages to upgrade, select a small
package which is unlikely to impact anything [1] such as a game e.g.
fortune-mod.

The next screen will allow you to choose if and where to install LILO.
On rebooting into linux, check /etc/lilo.conf, amend if necessary (the
install program may add another option at the end) and run lilo to reapply.

[1] you might even get away with selecting none - I didn't try that.
 
 
 

using knoppix to restore lilo <== found workaround

Post by Andreas Ja » Sun, 15 Feb 2004 02:04:36

Hello






Don't use lilo from Knoppix, use lilo from your hard disk installation.
Mount it somewhere, do

chroot /path/to/redhat

mount needed additional directories like /boot, and run lilo. That way
you will automatically use the lilo.conf and lilo from your Red Had
system.

best regards
Andreas Janssen

--
Andreas Janssen
XXXX@XXXXX.COM
PGP-Key-ID: 0xDC801674
Registered Linux User #267976

 
 
 

using knoppix to restore lilo <== found workaround

Post by David Dout » Wed, 18 Feb 2004 09:54:33

On Fri, 13 Feb 2004 15:19:09 +0100, "Hognoxious"





sudo works fine. There is also a menu option in the KDE menu under
Knoppix which provides a root shell.


Knoppix is based on Debian and contains leading edge versions of
software from Debian.


David Douthitt ( XXXX@XXXXX.COM )
UNIX System Administrator
HP-UX, Unixware, Linux
Linux+, LPIC-1