bridging problem -- bridge needs IP address

bridging problem -- bridge needs IP address

Post by Pete » Wed, 23 Feb 2005 01:16:36


Hi everyone,

i tried to set up a bridge with my fedora core 3, kernel
2.6.10-1.741_FC3. I entered following commands:

# ifconfig eth0 promisc up
# ifconfig eth1 promisc up
# brctl addbr br0
# brctl addif br0 eth0
# brctl addif br0 eth1
# ifconfig br0 up

It was possible to create the bridge, but there is a problem: The
bridge doesn't forward traffic until i assign an IP address to the
interface br0. But that's not what i want.
Any ideas?

Greetings

Peter
 
 
 

1. GMFBridge problem: how to re-bridge after un-bridge?

2. sudden network problem with "bridge" "bridging"

i have two connection in my pc in LAN.
switch is D-Link
Network card
100mbps 192.168.1.12
10 mbps 192.168.1.11
i select both of them and right click "bridge connections"
my switch and my lan Asleep.
ping not work 1/50 replied.
i think follow thw concept of Bridge :

when i bridge that 2 connection with together , my lan apart two part
on what logically reason?
therefor the result of bridge is:
connect two network by low back bone speed.
and not allow to broadcast massages.

3. ADSL Bridge - IP Address to ping and for management

4. Bridge Serial and Ethernet interfaces to pass ISP static IP address through

5. I have 4 NIC cards on Linux PC, can I assign Ip address to bridge interface?

6. static ip address on a network bridge

7. Network Bridge IP address conflict

8. Network Bridge & Wrong IP Address

9. winxp bridge generates dupicate IP address(MAC)

10. Network Bridge - Cable unplugges - MAC Bridge Miniport

11. Wireless bridge using XP bridge on laptop - can't get it to work!

12. PCI-X bridge from Xilinx LogiCORE and half bridge

13. Bridge connections - but no bridge!

14. NIC part of bridge, but Network Bridge itself is gone (Win XP Pro)

15. [PATCH bridge-2.6.11] bridge hub_enabled option