TP a22p (Ati Mobility M3), mp4player, mplayer etc

TP a22p (Ati Mobility M3), mp4player, mplayer etc

Post by Heiko Reck » Thu, 14 Jul 2005 23:12:28


Hi,

dont know what it is caused by, it happens on FreeBSD as well, Xorg,
mp4player (mpeg4ip.sf.net) and mplayer.

The windows opens in the expected size and mp4player etc
just display an distorted image in the upper half of the screen, the
rest is black. The y axis of the movie is only half as long as
expected.

Is Xorg broken, do I have settings wrong?
There are some pages in the net on a22p Thinkpads, this problem is
never mentioned.


Thanks,


H.
 
 
 

TP a22p (Ati Mobility M3), mp4player, mplayer etc

Post by Dances Wit » Thu, 14 Jul 2005 23:48:04

On Wed, 13 Jul 2005 16:12:28 +0200, Heiko Recktenwald staggered into the
Black Sun and said:

Message rearranged a bit for clarity.


I've seen this before, but it was a long time ago and on XFree, not
Xorg. It's a problem with the Xv extension and the r128 graphics
chipset. When I was using XFree, I solved the problem by using the
GATOS X module for r128 instead of the XFree standard module. I haven't
seen this problem with Xorg. http://www.yqcomputer.com/
temporary workaround, you could use the movie players' X11 video output
instead of the Xv video output. That's "-vo x11" for mplayer.


Like I said, the only time I've seen this happen was years ago with old
XFree.

--
Matt G|There is no Darkness in Eternity/But only Light too dim for us to see
Brainbench MVP for Linux Admin / mail: TRAP + SPAN don't belong
http://www.yqcomputer.com/ /
-----------------------------/ This space sort of for rent.

 
 
 

TP a22p (Ati Mobility M3), mp4player, mplayer etc

Post by Heiko Reck » Sun, 17 Jul 2005 02:18:27

Black Sun,

On Wed, 13 Jul 2005 09:48:04 -0500, Dances With Crows




No solution for the Cisco mp4player and I am on Windows in this
moment, havent yet tested it, anyway, the secrets of xorg...

Thanks!


H.
 
 
 

TP a22p (Ati Mobility M3), mp4player, mplayer etc

Post by Heiko Reck » Sun, 24 Jul 2005 00:22:34

>>> [When I try to play movies on a Thinkpad A22p,] the windows open in

Well, currently I am using the vesa driver.
With mplayer, I get at least the ordinary movie,
not worse than x11 (IMHO), with mp4player I get the
fullscreen too.

Maybe I should try the gatos driver with xorg as well.


H.