Oracle 9i (R2) on FC4, close but still stuck

Oracle 9i (R2) on FC4, close but still stuck

Post by rober » Sat, 22 Jul 2006 23:59:29


Hi all, I posted this in the fedora forums but that I'd give usenet a
try.

I'm following this guide:

http://www.yqcomputer.com/

I can run the installer, but I'm getting linking errors on files like:

Error in invoking target install of makefile
/opt/oracle/920/precomp/lib/ins_precomp.mk

Here is what I've got:

gcc-4.0.2-8.fc4
glibc-headers-2.3.5-10
glibc-kernheaders-2.4-9.1.94
glibc-devel-2.3.5-10
o pacote compat-libstdc++ n est?instalado
cpp-4.0.2-8.fc4
compat-gcc-7.3-2.96.126

So compat-libstdc++ maybe a problem - but I can do this so it appears
to be installed:

rpm -qa | grep compat-libstdc++
compat-libstdc++-296-2.96-132.fc4
compat-libstdc++-33-3.2.3-47.fc4

One other clue: I _cannot_ set LD_ASSUME_KERNEL=2.4.1 !!! If I do, I
get:

uname: /usr/lib/libc.so.6: version `GLIBC_2.3' not found (required by
uname)

Trying to run the installer I get:

/home/oracle> /home/CD/Disk1/Disk1/install/linux/runInstaller


!!! WARNING !!! --> libc-2.2.2-stub.so

This is a stub library which can be used for linking only. It must
*not*
be used as a runtime library. Please make sure this library is not
found
in LD_LIBRARY_PATH.

Without LD_ASSUME_KERNEL=2.4.1 , I can at least run the installer. I
think I have gcc and all the libs configured: gcc --version
2.96

Any ideas? Please help!
Robert
 
 
 

Oracle 9i (R2) on FC4, close but still stuck

Post by Michael He » Sun, 23 Jul 2006 02:17:32

In comp.os.linux.setup robert < XXXX@XXXXX.COM >:





Oracle isn't supported on FC <whatever>. I'd strongly recommend
to use RHEL (4) or one of the free clones (centos/etc) if you
don't need the support. You can find a good install guide:

http://www.yqcomputer.com/

Good luck

--
Michael Heiming (X-PGP-Sig > GPG-Key ID: EDD27B94)
mail: echo XXXX@XXXXX.COM | perl -pe 'y/a-z/n-za-m/'
#bofh excuse 360: Your parity check is overdrawn and you're
out of cache.