Problems installing Oracle 9i (9.2.0.4.0) Client on Linux Fedora Core 3

Problems installing Oracle 9i (9.2.0.4.0) Client on Linux Fedora Core 3

Post by jose_luis_ » Fri, 25 Feb 2005 23:19:13



Hi,

When I run the "runInstaller" script, the message below is shown:

[oracle@llamas Disk1]$ ./runInstaller
[oracle@llamas Disk1]$ Initializing Java Virtual Machine from
/tmp/OraInstall2005-02-24_03-10-39PM/jre/bin/java. Please wait...
Error occurred during initialization of VM
Unable to load native library:
/tmp/OraInstall2005-02-24_03-10-39PM/jre/lib/i386/libjava.so: symbol
__libc_wait, version GLIBC_2.0 not defined in file libc.so.6 with link
time reference



Any hint ?

Thanks in advance,
Jose Luis.
 
 
 

Problems installing Oracle 9i (9.2.0.4.0) Client on Linux Fedora Core 3

Post by Davide Bia » Fri, 25 Feb 2005 23:45:15


IIRC Oracle is compiled agains an old version of the LibC, so if you
want to use it you need to install a "compatible" library.
I think that you can find a lot of info just googling with such
error message.

Davide

--
The best Windows accelerator is that which works at 9.81 m/s2
-- From a Slashdot.org post

 
 
 

Problems installing Oracle 9i (9.2.0.4.0) Client on Linux Fedora Core 3

Post by Laurenz Al » Fri, 25 Feb 2005 23:52:21


The Java Runtime Environment that obviously comes with the installer
does not work with the C library that you have installed.

I searched the web for you, and arrived at
http://www.yqcomputer.com/ #sthref106
which tells me that you need
SuSE Linux Enterprise Server 7 with kernel 2.4.7, and glibc 2.2.2

While you can probably ignore the SuSE requirement, the glibc prerequisite
makes sense.

What glibc do you have installed?

Yours,
Laurenz Albe
 
 
 

Problems installing Oracle 9i (9.2.0.4.0) Client on Linux Fedora Core 3

Post by Laurenz Al » Fri, 25 Feb 2005 23:59:23


Sorry, I goofed up.
The correct link for your version seems to be
http://www.yqcomputer.com/ #BABJEGDH

Which gives recommendations for
Red Hat Enterprise Linux 2.1 and Red Hat Enterprise Linux 3

Yours,
Laurenz Albe
 
 
 

Problems installing Oracle 9i (9.2.0.4.0) Client on Linux Fedora Core 3

Post by jose_luis_ » Sat, 26 Feb 2005 00:03:59


glibc-2.3.4

Regards,
Jose Luis.



symbol
link
prerequisite
 
 
 

Problems installing Oracle 9i (9.2.0.4.0) Client on Linux Fedora Core 3

Post by jose_luis_ » Sat, 26 Feb 2005 00:21:16


I only want install the Client because I need it to run "tora" (Toolkit
for Oracle). Is it posible to install it on Fedora Core 3 ?

Regards,
Jose Luis.
 
 
 

Problems installing Oracle 9i (9.2.0.4.0) Client on Linux Fedora Core 3

Post by Malt » Sat, 26 Feb 2005 01:03:35


Here's some more info that may prove helpful.

http://www.yqcomputer.com/ ,295199,sid63_gci1053266,00.html
 
 
 

Problems installing Oracle 9i (9.2.0.4.0) Client on Linux Fedora Core 3

Post by mjt » Sat, 26 Feb 2005 01:59:51


export LD_ASSUME_KERNEL=2.2.5

might want to put that in ~/.bashrc
and ~/.profile to be safe

--
<< http://www.yqcomputer.com/ ;>
Sooner or later you must pay for your sins. (Those who have already
paid may disregard this fortune).
 
 
 

Problems installing Oracle 9i (9.2.0.4.0) Client on Linux Fedora Core 3

Post by Michael He » Sat, 26 Feb 2005 04:20:31

In comp.os.linux.misc XXXX@XXXXX.COM :

[..]


If there are those various compat-*.rpm (compat-glibc*.rpm/etc)
packages available for Fedora, as they come with rh, it shouldn't
be a problem, once you have installed those.

--
Michael Heiming (X-PGP-Sig > GPG-Key ID: EDD27B94)
mail: echo XXXX@XXXXX.COM | perl -pe 'y/a-z/n-za-m/'
#bofh excuse 325: Your processor does not develop enough heat.