x reinits every 2 sec before login

x reinits every 2 sec before login

Post by Tim » Fri, 25 Jun 2004 05:24:20


Hi

I have a strange problem that I have pinpointed as good as I can for several
hours now but I am stumped and don't know how to fix it or where to look for
more info.

Before I get to the graphical loginscreen I usually se a textbased login
prompt for a second or so, then it goes a way and a graphical one comes
instead. (gdm I think)

The same happens now, I see the loginscreen and it goes away but now no
graphical thing comes up. Instead I get thrown back to the textbased login.
The textbased is shown a second or so before it tries again, this is
repeated indefinitley.

If I typ really fast I can login at the textbased prompt but even when I am
logged in I can only se the promp one sec at the time before it goes black
and tries to start gdm again.

I used a rescue disc and changed the default runlevel to 3 then there is no
problem and I can do whatever I want but if I try to run
/etc/X11prefdm -nodaemon I get the same problem, it keeps trying to restart
something every sec or so.

prefdm is acording to inittab is the command that is isued in runlevel 5

This is just a script that looks at /etc/sysconfig/desktop to se wich my
preffered desktop is. This file only contains

DESKTOP=GNOME

I tried to Change it to DESKTOP=XDM but the same thing happens.

I don't get much from a dmesg, only this

kernel: [drm] Initialized radeon 1.11.0 20020828 on minor 0
kernel: agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
kernel: agpgart: Putting AGP V2 device at 0000:00:00.0 into 1x mode
kernel: agpgart: Putting AGP V2 device at 0000:02:00.0 into 1x mode

I am not sure but I think that is something I have seen before and that is
okey.

I am using fedora core 2 with the latest kernel 2.6.6-1.435 and Xorg and
GNOME on an IBM thinkpad r40

I am not familiar with the bootprocess or xstartup process but it prefdm
aperently starts gdm and gdm is a script that reads a profile and starts
gdm-binary.

Is there a way to reinstal or in some other way fix this gdm issue?

I rember that used the automatic updater that is included in fedora
(up2date) and updated gimp recently I might not have rebooted the computer
between that update and now but I am not sure. Could that have affected some
graphics lib? If so, can I undo that update with yum or so?

Any pointers are apreciated I think I am all out of ideas no.

whew

Tim
 
 
 

x reinits every 2 sec before login

Post by alyun » Mon, 28 Jun 2004 00:13:24

Your problem is caused by an improper X configuration. Just stay with
runlevel 3 until you can get a stable graphical desktop. This is how
you start graphical desktop from the shell prompt of text mode:
startx
The log "/var/log/XFree86.0.log" should tell you what the problem is.
It looks like you are using some kind ATI video card. I would start
looking at "dri" or "drm" from the log.


: Hi

: I have a strange problem that I have pinpointed as good as I can for several
: hours now but I am stumped and don't know how to fix it or where to look for
: more info.

: Before I get to the graphical loginscreen I usually se a textbased login
: prompt for a second or so, then it goes a way and a graphical one comes
: instead. (gdm I think)

: The same happens now, I see the loginscreen and it goes away but now no
: graphical thing comes up. Instead I get thrown back to the textbased login.
: The textbased is shown a second or so before it tries again, this is
: repeated indefinitley.

: If I typ really fast I can login at the textbased prompt but even when I am
: logged in I can only se the promp one sec at the time before it goes black
: and tries to start gdm again.

: I used a rescue disc and changed the default runlevel to 3 then there is no
: problem and I can do whatever I want but if I try to run
: /etc/X11prefdm -nodaemon I get the same problem, it keeps trying to restart
: something every sec or so.

: prefdm is acording to inittab is the command that is isued in runlevel 5

: This is just a script that looks at /etc/sysconfig/desktop to se wich my
: preffered desktop is. This file only contains

: DESKTOP=GNOME

: I tried to Change it to DESKTOP=XDM but the same thing happens.

: I don't get much from a dmesg, only this

: kernel: [drm] Initialized radeon 1.11.0 20020828 on minor 0
: kernel: agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
: kernel: agpgart: Putting AGP V2 device at 0000:00:00.0 into 1x mode
: kernel: agpgart: Putting AGP V2 device at 0000:02:00.0 into 1x mode

: I am not sure but I think that is something I have seen before and that is
: okey.

: I am using fedora core 2 with the latest kernel 2.6.6-1.435 and Xorg and
: GNOME on an IBM thinkpad r40

: I am not familiar with the bootprocess or xstartup process but it prefdm
: aperently starts gdm and gdm is a script that reads a profile and starts
: gdm-binary.

: Is there a way to reinstal or in some other way fix this gdm issue?

: I rember that used the automatic updater that is included in fedora
: (up2date) and updated gimp recently I might not have rebooted the computer
: between that update and now but I am not sure. Could that have affected some
: graphics lib? If so, can I undo that update with yum or so?

: Any pointers are apreciated I think I am all out of ideas no.

: whew

: Tim