Dual Head flgrx M9 ATI 9000 problems on a Dell Laptop

Dual Head flgrx M9 ATI 9000 problems on a Dell Laptop

Post by michael.he » Wed, 19 May 2004 01:39:09


y guys,

I'm trying to get the dual head running on a Dell D600.
When the second screen is activated in the XF86Config I get the error
"GetBIOSParameter failed"
My first monitor is a 18,1" LCD connected via DVI and the second
monitor is the internal Laptop LCD.
I am using the actual ATI driver.

Log:

(EE) fglrx(0): The desktop configuration requires two monitors,
but only one monitor is configured or detected.
Please have both monitors connected or use
MonitorLayout option to specify both monitors
(EE) fglrx(0): GetBIOSParameter failed
(EE) fglrx(0): R200PreInit failed
(II) fglrx(0): === [R200PreInit] === end
(II) fglrx(1): === [R200PreInit] === begin, [s]
(EE) fglrx(1): Quitting secondary screen -- no monitor specified.
(EE) fglrx(1): R200PreInit failed
(II) fglrx(1): === [R200PreInit] === end
(II) UnloadModule: "fglrx"
(II) UnloadModule: "i2c"
(II) Unloading /usr/X11R6/lib/modules/libi2c.a
(II) UnloadModule: "ddc"
(II) Unloading /usr/X11R6/lib/modules/libddc.a
(II) UnloadModule: "int10"
(II) Unloading /usr/X11R6/lib/modules/linux/libint10.a
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(II) UnloadModule: "fglrx"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

But actually I do have configured the second monitor.

My XF86Config:

Section "Monitor"
Identifier "Monitor1"
HorizSync 28 - 90
VertRefresh 60 - 100
Option "DPMS"
# 1400x1050 @ 60Hz M9 Laptop mode
# ModeLine "1400x1050" 122.000 1400 1488 1640 1880 1050 1052 1064 1082
+hsync +vsync
Modeline "1280x1024" 105.15 1280 1360 1496 1712 1024 1025 1028 1059
EndSection


Section "Monitor"
Identifier "Monitor0"
HorizSync 28 - 90
VertRefresh 60 - 100
Option "DPMS"
#Modeline "1280x1024" 105.15 1280 1360 1496 1712 1024 1025 1028 1059
ModeLine "1400x1050" 122.000 1400 1488 1640 1880 1050 1052 1064 1082
+hsync +vsync

EndSection
Section "Device"
Identifier "ATI Graphics Adapter
connector 0"
Driver "fglrx"
# ### generic DRI settings ###
# === disable PnP Monitor ===
#Option "NoDDC"
# === disable/enable XAA/DRI ===
Option "no_accel" "no"
Option "no_dri" "no"
# === misc DRI settings ===
Option "mtrr" "off" # disable DRI mtrr
mapper, driver has its own code for mtrr
# ### FireGL DDX driver module specific settings ###
# === Screen Management ===
Option "DesktopSetup" "0x00000000"
Option "MonitorLayout" "AUTO, AUTO"
Option "IgnoreEDID" "off"
Option "HSync2" "31.5 - 91.1"
Option "VRefresh2" "60 - 100"
Option "ScreenOverlap" "0"
# === TV-out Management ===
Option "NoTV" "yes"
Option "TVStandard" "NTSC-M"
Option "TVHSizeAdj" "0"
Option "TVVSizeAdj" "0"
Option "TVHPosAdj" "0"
Option "TVVPosAdj" "0"
Option "TVHStartAdj" "0"
Option "TVColorAdj" "0"
Option "GammaCorrectionI" "0x00000000"
Option "GammaCorrectionII" "0x00000000"
# === OpenGL specific profiles/settings ===
Option "Capabilities" "0x00000000"
 
 
 

Dual Head flgrx M9 ATI 9000 problems on a Dell Laptop

Post by Dances Wit » Wed, 19 May 2004 02:13:35

On 17 May 2004 09:39:09 -0700, Michael Henkel staggered into the Black
Sun and said:

Your config file isn't right.

[snip]
[snip]
[snip]

Note that both of your Screen sections specify Monitor1. You want to
have one of them specifying Monitor0 and the other one specifying
Monitor1.


This should be OK.

--
Matt G|There is no Darkness in Eternity/But only Light too dim for us to see
Brainbench MVP for Linux Admin / mail: TRAP + SPAN don't belong
http://www.yqcomputer.com/ / Hire me!
-----------------------------/ http://www.yqcomputer.com/ ~mhgraham/resume

 
 
 

Dual Head flgrx M9 ATI 9000 problems on a Dell Laptop

Post by michael.he » Wed, 19 May 2004 23:15:03


Thx for the quick answer, but I tried it also with
[snip]
[snip]

without success. Is it generally possible to
a. Use different resolutions on two monitors
(Monitor a: extern dvi 1280x1024
Mointor b: intern 1400x1050)
b. to use the internal laptop monitor as the second monitor.

From what I have heart is that the DVI jack is always numerated as
jack 1, is that right?
Ah, and the laptop uses a docking station but this should make no
difference.

Thanks again,

Michael
 
 
 

Dual Head flgrx M9 ATI 9000 problems on a Dell Laptop

Post by michael.he » Sun, 23 May 2004 02:42:44


I am using a docking station for the laptop. I tried the analog VGP
adapter instead of the digital DVI adapter and the dual head worked.
Seems that XFREE cannot detect the monitor which is connected to the
DVI adapter.
Does anyone know why?