[tao-users] [ace-users] Difficulties in building ACE-TAO with Unicode support

[tao-users] [ace-users] Difficulties in building ACE-TAO with Unicode support

Post by Johnny Wil » Sat, 26 May 2007 19:47:40


his is a multi-part message in MIME format.


Hi,

TAO can't be fully build with wchar support, only ACE can. For TAO still a
lot has to be done, this is an activity that needs sponsoring from the user
community. I would recommend you to upgrade to x.5.8, it addresses already
several problems You contact me directly to discuss the options.

Regards,

Johnny Willemsen
Remedy IT
Postbus 101
2650 AC Berkel en Rodenrijs
The Netherlands
www.theaceorb.nl / www.remedy.nl

*** Integrated compile and test statistics see http://remedy.nl
<http://remedy.nl/> ***
*** Commercial service and support for ACE/TAO/CIAO ***
*** See http://www.theaceorb.nl/en/support.html ***


_____

From: XXXX@XXXXX.COM
[mailto: XXXX@XXXXX.COM ] On Behalf Of A.T.karthikeyan
Sent: Friday, May 25, 2007 11:57 AM
To: XXXX@XXXXX.COM ; XXXX@XXXXX.COM
Subject: [ace-users] Difficulties in building ACE-TAO with Unicode support


Hi All,
My company product is based on ACE/TAO framework. I suppose to
built my product with unicode support. So that I'm trying to built ACE/TAO
with unicode support in windows vc 6.0 environment. We are now using ACE
version 5.3a_p13 and TAO version 1.3a_p13. I have changed the congif.h file
in ace folder and add the macro called ACE_USES_WCHAR to ace use wchar_t
internally. After that ACE compilation was fine but when I try to built the
TAO it shown me lot of char to unsigned sort and vice versa convesion
problems. Do I suppose to bulit ACE with ACE_USES_WCHAR macro to built our
product with Unicode support? What is the difference between defining
ACE_USES_WCHAR and ACE_HAS_WCHAR? Is there any option in TAO to built with
wchar support? or it is fine if we enabled wchar support in ACE alone. Later
I have tried with latest version of ACE 5.5 and TAO 1.5. It's also shown me
a lot of conversion problem. My basic question is what I suppose to change
in ACE/TAO to support wchar. Can you please any one tell me how do I built
my ACE-TAO stuff. It is very urgent.

Thanks,
Karthikeyan


With regards,
Er,Karthikeyan , DCT.,MCP.,MCAD.,MCSD
Software Engineer,
Checktronix Pvt Ltd.



_____

Be a better Globetrotter. Get
<http://us.rd.yahoo.com/evt=48254/*http://answers.yahoo.com/dir/_ylc=X3oDMTI
5MGx2aThyBF9TAzIxMTU1MDAzNTIEX3MDMzk2NTQ1MTAzBHNlYwNCQUJwaWxsYXJfTklfMzYwBHN
sawNQcm9kdWN0X3F1ZXN0aW9uX3BhZ2U-?link=list&sid=396545469> better travel
answers from someone who knows.
Yahoo! Answers - Check it out.


<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=us-ascii">
<META content="MSHTML 6.00.6000.16414" name=GENERATOR></HEAD>
<BODY>
<DIV dir=ltr align=left><SPAN class=343534510-25052007><FONT face=Arial
color=#0000ff size=2>Hi,</FONT></SPAN></DIV>
<DIV dir=ltr align=left><SPAN class=343534510-25052007><FONT face=Arial
color=#0000ff size=2></FONT></SPAN> </DIV>
<DIV dir=ltr align=left><SPAN class=343534510-25052007><FONT face=Arial
color=#0000ff size=2>TAO can't be fully build with wchar support, only ACE can.
For TAO still a lot has to be done, this is an activity that needs sponsoring
from the user community. I would recommend you to upgrade to x.5.8, it addresses
already several p