[wx 2.4.2, macOSX.3, CodeWarrior 8.0] linking problem on Mac build

[wx 2.4.2, macOSX.3, CodeWarrior 8.0] linking problem on Mac build

Post by stal » Wed, 23 Jun 2004 18:02:49


Hi all,

We've been using wxWindows/Widgets for a couple years now and have been
quite happy with the results. So far, we've only been building Windows apps
but I've been try to build a Mac (Carbon) version of one of our new apps
using CodeWarrior. I'm not an Apple guru by any stretch but I have managed
to get everything to compile and (almost) link. I've got one link error
that I can get rid of and it shows up on both debug and release versions.
If anyone can shed some light on this one, you'll save me some gray hairs.
Thanks!

It seems to be referenced entirely within wx_CARBON[_d].lib:

Link Error : undefined: '__assertion_failed' (code)
Referenced from 'TIFFGrowStrips' in wx_CARBON.lib
Referenced from '_TIFFSwab64BitData' in wx_CARBON.lib Referenced from
'_TIFFSwab32BitData' in wx_CARBON.lib Referenced from '_TIFFSwab16BitData'
in wx_CARBON.lib Referenced from 'LogLuvEncodeTile' in wx_CARBON.lib
Referenced from 'LogLuvEncodeStrip' in wx_CARBON.lib Referenced from
'LogL16Encode' in wx_CARBON.lib Referenced from 'LogLuvEncode32' in
wx_CARBON.lib Referenced from 'LogLuvEncode24' in wx_CARBON.lib Referenced
from 'LogLuvDecodeTile' in wx_CARBON.lib Referenced from 'LogLuvDecodeStrip'
in wx_CARBON.lib Referenced from 'LogL16Decode' in wx_CARBON.lib Referenced
from 'LogL16InitState' in wx_CARBON.lib Referenced from 'LogLuvDecode32' in
wx_CARBON.lib Referenced from 'LogLuvDecode24' in wx_CARBON.lib Referenced
from 'LogLuvInitState' in wx_CARBON.lib Referenced from 'TIFFInitSGILog' in
wx_CARBON.lib Referenced from 'Fax3PreEncode' in wx_CARBON.lib Referenced
from 'Fax3PreDecode' in wx_CARBON.lib Referenced from '_TIFFFax3fillruns' in
wx_CARBON.lib Referenced from '_TIFFFieldWithTag' in wx_CARBON.lib
Referenced from 'putspan' in wx_CARBON.lib Referenced from
'PackBitsEncodeChunk' in wx_CARBON.lib Referenced from 'PredictorEncodeTile'
in wx_CARBON.lib Referenced from 'PredictorEncodeRow' in wx_CARBON.lib
Referenced from 'PredictorDecodeTile' in wx_CARBON.lib Referenced from
'PredictorDecodeRow' in wx_CARBON.lib Referenced from 'LZWPreEncode' in
wx_CARBON.lib Referenced from 'LZWSetupEncode' in wx_CARBON.lib Referenced
from 'LZWPreDecode' in wx_CARBON.lib Referenced from 'LZWDecodeCompat' in
wx_CARBON.lib Referenced from 'LZWSetupDecode' in wx_CARBON.lib Referenced
from 'TIFFInitLZW' in wx_CARBON.lib Referenced from 'LZWDecode' in
wx_CARBON.lib Referenced from 'LZWEncode' in wx_CARBON.lib




---------------------------------------------------------------------
To unsubscribe, e-mail: XXXX@XXXXX.COM
For additional commands, e-mail: XXXX@XXXXX.COM
 
 
 

[wx 2.4.2, macOSX.3, CodeWarrior 8.0] linking problem on Mac build

Post by ryanwilco » Wed, 23 Jun 2004 22:22:24

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 6/22/04, at 3:01 AM, Derek Stal said:



Ummm... Just a guess, but perhaps you don't have Enable Exceptions enabled in
the target settings in the wxWindowsM8.mcp?

Hope this helps,
_Ryan Wilcox

================================================================
Wilcox Development Solutions: http://www.yqcomputer.com/
Toolsmiths for the Internet Age PGP: 0x2F4E9C31

-----BEGIN PGP SIGNATURE-----
Version: PGP SDK 3.0.3

iQA/AwUBQNgygG2DtKgvTpwxEQJ3bACdH6+Y2kSw6hOhbYE+O0XwyGEGrMUAoLRs
ds3rFp9grrtBeqBWS6VjmNq6
=hkXB
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: XXXX@XXXXX.COM
For additional commands, e-mail: XXXX@XXXXX.COM