wxGTK and wxMSW look and feel

wxGTK and wxMSW look and feel

Post by vadi » Sun, 08 Oct 2006 07:40:38



EL> I have an executable encadre-image.exe which is running fine but doesn't
EL> have the look and feel of XP...
EL>
EL> Am I missing something ?

You're missing the manifest which is needed to enable XP theming. Please
search this list archives for this keyword.

Regards,
VZ

--
TT-Solutions: wxWidgets consultancy and technical support
http://www.yqcomputer.com/


---------------------------------------------------------------------
To unsubscribe, e-mail: XXXX@XXXXX.COM
For additional commands, e-mail: XXXX@XXXXX.COM
 
 
 

wxGTK and wxMSW look and feel

Post by robi » Sun, 08 Oct 2006 07:47:08


You also need to use a wxPanel between your frame and the controls.

--
Robin Dunn
Software Craftsman
http://www.yqcomputer.com/ Java give you jitters? Relax with wxPython!


---------------------------------------------------------------------
To unsubscribe, e-mail: XXXX@XXXXX.COM
For additional commands, e-mail: XXXX@XXXXX.COM

 
 
 

wxGTK and wxMSW look and feel

Post by elal » Sun, 08 Oct 2006 23:45:24

Robin Dunn a rit :


OK, not yet really clear for me...
If I include wx.rc there are some compilation errors.
After some searches and having read the Makefile of the controls sample
(in wxw sources), I've understood that I must link the object foo.o
("compiled" from foo.rc) with my other object.
I've now a .exe which is running and the controls are correctly drawed.
As I said, not yet really understand, but at least it's almost
working... (will see after to really understand ;-) )

That must be why "it's almost working": the controls are correctly
drawed but the bottom is gray.
I'll try with a panel.
But I'm asking just why this is working under wxgTK without a wxPanel ?

Thanks to you two.

ic.

---------------------------------------------------------------------
To unsubscribe, e-mail: XXXX@XXXXX.COM
For additional commands, e-mail: XXXX@XXXXX.COM
 
 
 

wxGTK and wxMSW look and feel

Post by elal » Mon, 09 Oct 2006 00:07:51

Vadim Zeitlin a rit :

OK, but under gnome if I launch my app the background color matches my
theme.
And if I change my theme, in gnome panel, while my app is running the
background (and the controls and...) of my app will be changed too.

Is it because gnome changing the color of wxFrame ?

Regards.

ic.


---------------------------------------------------------------------
To unsubscribe, e-mail: XXXX@XXXXX.COM
For additional commands, e-mail: XXXX@XXXXX.COM