disaster :(

disaster :(

Post by orang » Sat, 28 Apr 2007 19:19:55


Please help me, Solaris 10 (x86) won't boot at all. I think the
problem is I did a foolish thing:
installed (new) SAMBA package even though it was already there and
then removed it (new one).
I guess uninstall took some system files with it. :((
I'm a newbie and don't know how to deal with this.

There is an error message, something like this:
..svc.startd .. svc/method/fs-root error exit status 95



here is the output from suggested commands:
--=--
/>svcs -x

svc:/system/filesystem/root:default (root file system mount)
State: maintenance since Fri Apr 27 12:50:42 2007
Reason: Start method exited with $SMF_EXIT_ERR_FATAL.
See: http://sun.com/msg/SMF-8000-KS
See: /etc/svc/volatile/system-filesystem-root:default.log
Impact: 51 dependent services are not running. (Use -v for list.)

svc:/network/rpc/smserver:default (removable media management)
State: uninitialized since Fri Apr 27 12:50:46 2007
Reason: Restarter svc:/network/inetd:default is not running.
See: http://sun.com/msg/SMF-8000-5H
See: rpc.smserverd(1M)
Impact: 1 dependent service is not running. (Use -v for list.)

--=--
/>svcs -v

STATE NSTATE STIME CTID FMRI
online - 12:50:40 4 svc:/system/svc/
restarter:default
online - 12:50:42 - svc:/network/pfil:default
online - 12:50:42 - svc:/network/
loopback:default
online - 12:50:44 - svc:/system/
installupdates:default
online - 12:50:45 - svc:/milestone/name-
services:default
online - 12:50:47 - svc:/network/
service:default
online - 12:50:48 - svc:/network/
physical:default
online - 12:50:48 - svc:/milestone/
network:default
online - 12:50:49 - svc:/system/identity:node
offline - 12:50:41 - svc:/system/boot-
archive:default
offline - 12:50:41 - svc:/system/device/
local:default
offline - 12:50:41 - svc:/system/filesystem/
usr:default
offline - 12:50:41 - svc:/system/
scheduler:default
offline - 12:50:42 - svc:/system/filesystem/
minimal:default
offline - 12:50:42 - svc:/system/manifest-
import:default
offline - 12:50:42 - svc:/system/
sysevent:default
offline - 12:50:42 - svc:/system/device/fc-
fabric:default
offline - 12:50:42 - svc:/milestone/
devices:default
offline - 12:50:42 - svc:/system/
identity:domain
offline - 12:50:42 - svc:/system/
cryptosvc:default
offline - 12:50:42 - svc:/system/
keymap:default
offline - 12:50:42 - svc:/milestone/single-
user:default
offline - 12:50:42 - svc:/system/filesystem/
local:default
offline - 12:50:42 - svc:/system/sysidtool:net
offline - 12:50:42 - svc:/milestone/
sysconfig:default
offline - 12:50:42 - svc:/system/
sysidtool:system
offline - 12:50:42 - svc:/platform/i86pc/
kdmconfig:default
offline - 12:50:42 - svc:/network/rpc/
bind:default
offline - 12:50:42 - svc
 
 
 

disaster :(

Post by orang » Sat, 28 Apr 2007 20:07:27

I found the cause, its /etc/vfstab
I've restored it from backup and everything's fine now :)