SunFire T1000 memory

SunFire T1000 memory

Post by Frank Wink » Wed, 16 Apr 2008 21:28:48


Hi guys !

I have some strange effects on a SunFire T1000. Initially, it had 4 GB
installed, which OBP (4.20.0) correctly displayed as 4096 MB. I upgraded to
8 GB and ended up with 8084 MB. Now I was hoping that current firmware
version would cure that - so I upgraded to 4.27.7 and only have 8064 MB
left. What the hell is wrong here?


Sun Fire(TM) T1000, No Keyboard
Copyright 2007 Sun Microsystems, Inc. All rights reserved.
OpenBoot 4.27.7, 8064 MB memory available, Serial #70049566.
Ethernet address 0:14:4f:2c:df:1e, Host ID: 842cdf1e.


TIA

fw
 
 
 

SunFire T1000 memory

Post by Frank Wink » Wed, 16 Apr 2008 23:49:56

Hi guys !

I have some strange effects on a SunFire T1000. Initially, it had 4 GB
installed, which OBP (4.20.0) correctly displayed as 4096 MB. I upgraded to
8 GB and ended up with 8184 MB:

Sun Fire(TM) T1000, No Keyboard
Copyright 2005 Sun Microsystems, Inc. All rights reserved.
OpenBoot 4.20.0, 8184 MB memory available, Serial #70049566.
Ethernet address 0:14:4f:2c:df:1e, Host ID: 842cdf1e.

Now I was hoping that current firmware versions would cure that - so I
upgraded to 4.27.7 and only have 8064 MB left:

Sun Fire(TM) T1000, No Keyboard
Copyright 2007 Sun Microsystems, Inc. All rights reserved.
OpenBoot 4.27.7, 8064 MB memory available, Serial #70049566.
Ethernet address 0:14:4f:2c:df:1e, Host ID: 842cdf1e.

What the hell is wrong here?

TIA

fw

 
 
 

SunFire T1000 memory

Post by Greg Morte » Thu, 17 Apr 2008 05:05:10

In < XXXX@XXXXX.COM > Frank Winkler < XXXX@XXXXX.COM > writes:

...

I don't have an answer for you, but I saw the same thing with my 2GB
T1000 with 4.27.4. I asked on SDN*, but never got a reply.

Regards,
Greg

* http://www.yqcomputer.com/
--
\|/ ___ \|/ XXXX@XXXXX.COM +----- 2048R/38BD6CAB -----+
@~./'O o`\.~@ | 02BD EF81 91B3 1B33 64C2 |
/__( \___/ )__\ | 3247 6722 7006 38BD 6CAB |
`\__`U_/' +--------------------------+
 
 
 

SunFire T1000 memory

Post by Frank Wink » Thu, 17 Apr 2008 23:40:05


>* http://www.yqcomputer.com/

... and the really funny thing is that sometimes it's missing 8 MB,
sometimes 128.

Maybe the difference has to do with the LDOM hypervisor?

Confused

fw
 
 
 

SunFire T1000 memory

Post by Cydrome Le » Fri, 18 Apr 2008 00:05:16


technical things like counting RAM or running a website with an uptime
of more than 3% and response time of less than 20 minutes is too hard for
sun.
 
 
 

SunFire T1000 memory

Post by Cydrome Le » Fri, 18 Apr 2008 00:09:19


FWIW, here's what one machine here says, it has 2GB.

Sun Fire(TM) T1000, No Keyboard
Copyright 2008 Sun Microsystems, Inc. All rights reserved.
OpenBoot 4.27.11, 1920 MB memory available, Serial #69133985.
 
 
 

SunFire T1000 memory

Post by Bruce Esqu » Fri, 18 Apr 2008 01:31:47


Not to sound like captain obvious here but are you sure you are using the
right ram for that T1000?

The only time I remember running across the OBP giving the wrong ram size is
when we literally had a "bag of untested ram" and was using a SS20 to sort
out the mess. Not all of them were barcoded but physically looked the same.

Some must of been for "something else" because although it booted the OBP
would report like 248mb (using 32mb x 8) instead of the 256mb.

I don't know all the in's and out's of memory chips but there was some
explanation about a parity chip there or not there causing the improper
count.

In our case all the memory went back in the bag and the bag into the garbage
but just saying something sounds familar with your story.

-bruce
XXXX@XXXXX.COM
 
 
 

SunFire T1000 memory

Post by Greg Morte » Fri, 18 Apr 2008 03:52:21

In <fu59lj$ji6$ XXXX@XXXXX.COM > Bruce Esquibel < XXXX@XXXXX.COM > writes:


I don't know about the OP, but my T1000 (the one that reports "1920 MB")
came right from Sun.

Regards,
Greg
--
\|/ ___ \|/ XXXX@XXXXX.COM +----- 2048R/38BD6CAB -----+
@~./'O o`\.~@ | 02BD EF81 91B3 1B33 64C2 |
/__( \___/ )__\ | 3247 6722 7006 38BD 6CAB |
`\__`U_/' +--------------------------+