"Error on page" and error report on entity close

"Error on page" and error report on entity close

Post by RGFuIF » Sat, 10 Oct 2009 00:38:01


Greetings,

We have CRM 4.0 rollup 6 implemented from a CRM 3.0 upgrade about a month
ago. Recently, my users have been reporting an error report being generated
when they try to close (or save & close) any entity they have open. The
entity is closed (or saved and closed), and I have asked them not to send the
error report, but of course this needs to be resolved. I have noticed that
once the record is open, "error on page" will appear in the bottom left of
the dialog if you will receive the error report dialog, which doesn't happen
every time. Also, if I do an IISRESET, the problem seems to clear up for a
while, but that could be coincedental.

We did not see this issue for a couple of weeks after our upgrade, and it is
intermittent, so I don't think it is OnLoad() script-related. Otherwise, it
would fail every time, right?

I have seen the threads about anonymous access on certain directories
resolving this issue, but it didn't resolve it for me, so I will start a new
thread in hopes of finding the solution.
 
 
 

"Error on page" and error report on entity close

Post by Dave Irela » Sat, 10 Oct 2009 02:16:51

It's most likely on-load related, Dan, even though you don't see the error
everytime. Your onload script might be trying to process a specific field,
and if the field has data then there is no error, but if there's no data it
throws an error. That's just a for-example.

I'd disable the onload script and publish the change and see if the error
goes away. If it does, then you need to troubleshoot a script error. If
you change your privacy settings (Tools-->Options-->Privacy) to 'never
send...' errors, then when a script error does occur, you will see the
yellow triangle in the bottom left corner of the screen. You can
double-click on the triangle to get the actual error that's being thrown,
which should help you troubleshoot.

Dave Ireland

 
 
 

"Error on page" and error report on entity close

Post by RGFuIF » Sat, 10 Oct 2009 23:22:01

Dave,

I think you were right. I mentioned this to one of my add-in vendors and he
conformed that one of thier OnLoad() scripts had some trouble if it wasn't
the only code in the OnLoad() event. I have them looking at it now.

Thanks
Dan
 
 
 

"Error on page" and error report on entity close

Post by RGFuIF » Thu, 22 Oct 2009 00:13:08

Dave,

I just wanted to close the loop with you and the community that it was
OnLoad() related and our vendor was able to clean their scripting up to cause
the error to go away.

Thanks for your assistance!