CRM Adapter Installation (CRM 3.0 connector for GP 9.0)

CRM Adapter Installation (CRM 3.0 connector for GP 9.0)

Post by Fila » Fri, 23 Jun 2006 06:49:59


Hello,

I have installed the CRM connector, the GP connector and then the
Connector. Right after i have installed the Biztalk 2004 i receive an
error and the error mentions something about assembly customization. I
uninstalled everything and tryed to install every adapter again. After
de CRM adapter installation finishes there were no errors, but when i
look at the Installation Log i noticed this error:

21/06/2006 : 05:21:08 p.m. :ERROR :AdaptersSetup.CrmCustomize
:SetRolesForCustomEntities :Exception Violation of UNIQUE KEY
constraint 'UQ_RolePrivileges'. Cannot insert duplicate key in object
'RolePrivileges'.
The statement has been terminated. at
System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
at
Microsoft.MbsIntegration.Setup.SetupCrm.ExecuteUpdateQuery(SqlConnection
conn, String sqlQueryString)
at
Microsoft.MbsIntegration.Setup.CrmCustomize.SetRolesForCustomEntities()


What could be the problem, i m thinking that this error is the cause of
the error installation on the Connector.

By the way, i have:
Server 1: CRM
Server 2: GP 9 and Integration Server.

Thanks for your help.
Eduardo
 
 
 

CRM Adapter Installation (CRM 3.0 connector for GP 9.0)

Post by Fila » Sat, 24 Jun 2006 01:00:34

Hello,

I've reinstalled the CRM and tried to install again the adaptr and went
ok.. but i keep receiving an error when the conector is installing
Biztalk server 2004, and then i receive another error while registering
COM+ components, and then another error creating/configuring the
integration message queues (Error #430). Thanks

 
 
 

CRM Adapter Installation (CRM 3.0 connector for GP 9.0)

Post by Fila » Sat, 24 Jun 2006 01:04:47

Another thing, i just looked at the log of the installation and there
are these errors:

22/06/2006 : 11:51:02 a.m. :ERROR :BTSInstallerClass
:InstallBTSDepAssemblies :Deployment Failed for assembly C:\Program
Files\Microsoft Dynamics\Microsoft Dynamics CRM Connector for Microsoft
Dynamics GP\bin\Microsoft.MbsIntegration.ReceivePipeline.dll

22/06/2006 : 11:51:02 a.m. :ERROR :BTSInstallerClass
:InstallBTSDepAssemblies :Error Deployment Failed for assembly
C:\Program Files\Microsoft Dynamics\Microsoft Dynamics CRM Connector
for Microsoft Dynamics
GP\bin\Microsoft.MbsIntegration.ReceivePipeline.dll at
Microsoft.MbsIntegration.Setup.BTSInstallerClass.DeployAssembly(String
btsDir, String assemblyPath)
at
Microsoft.MbsIntegration.Setup.BTSInstallerClass.InstallBTSDepAssemblies(String
installDir, String btsDir)

22/06/2006 : 11:51:02 a.m. :DEBUG :BTSInstallerClass :Install
:Installing MainOrch Orchestration.

22/06/2006 : 11:51:02 a.m. :DEBUG :BTSConfigure :EnlistOrchestrations
:Enlist Orchestration Microsoft.MbsIntegration.MainOrch
BizTalkServerApplication

22/06/2006 : 11:51:04 a.m. :ERROR :BTSInstallerClass :Install
:Exception while enlisiting/starting orchestration Cannot open database
requested in login 'BizTalkMgmtDb'. Login fails.
Login failed for user 'DEMO\Administrator'.

22/06/2006 : 11:58:33 a.m. :ERROR :ComPlusInstaller :Install :Exception
Occured : Cannot open database requested in login 'CRMIntegration30'.
Login fails.
Login failed for user 'DEMO\Administrator'.
 
 
 

CRM Adapter Installation (CRM 3.0 connector for GP 9.0)

Post by Neha Bhaya » Sat, 24 Jun 2006 14:53:12

ello Fila,

These errors indicate that the BTS uninstall was not clean. Your machine's
Global Assembly Cache had some Dlls of the connector and BizTalk Server.
I suggest you do a clean uninstall (it involves some manual steps as
mentioned in installation guide) and the try and install the connector.

Thanks,
Neha
----------------------------------------------------------------------------------------------------------------------------------------------
Important: This posting is provided "AS IS" with no warranties, and confers
no rights. You assume all risk for your use.
----------------------------------------------------------------------------------------------------------------------------------------------


"Fila" < XXXX@XXXXX.COM > wrote in message
news: XXXX@XXXXX.COM ...


 
 
 

CRM Adapter Installation (CRM 3.0 connector for GP 9.0)

Post by Fila » Wed, 28 Jun 2006 06:06:31

hanks Neha, i will try that tomorrow..

Neha Bhayana wrote:

 
 
 

CRM Adapter Installation (CRM 3.0 connector for GP 9.0)

Post by Fila » Sun, 02 Jul 2006 06:12:53

ello Neha, i tried to do the same installation y two differents
servers and i keep receiving the same error.. any suggestions?

Thanks a lot

Eduardo.

Fila wrote:

 
 
 

CRM Adapter Installation (CRM 3.0 connector for GP 9.0)

Post by Fila » Sun, 02 Jul 2006 06:21:19

y the wat, this time i did it with GP 8.

Eduardo.

Fila wrote: