Workflow : Wait activity condition does not work

Workflow : Wait activity condition does not work

Post by FrankCR » Sun, 04 Nov 2007 04:25:28


I've created a very simple workflow that does not seem to work. The
rule is:
Manual Rule
Task: Task 1
wait
Task: Task 1 is completed
end wait
Task: Task 2

When I 'Save as completed' Task 1, Task 2 is not created.

I find the following entry in the EVent Log:
Event Type: Error
Event Source: MSCRMWorkflowService
Event Category: None
Event ID: 16649
Date: 11/1/2007
Time: 1:42:25 PM
User: N/A
Computer: AMCI-CRMPROD
Description:
Condition {BF1490AE-A188-DC11-9C5C-00C09F1E9CAA} failed in step
{BB1490AE-A188-DC11-9C5C-00C09F1E9CAA} of process instance {A71490AE-
A188-DC11-9C5C-00C09F1E9CAA}. Please view the paused rule in the
Microsoft.Crm.Workflow.Monitor for more information about the
failure.

But the rule is not paused, it's waiting and Task 2 never gets
created.

If I use the Workflow Monitor to pause and restart the workflow, then
Task 2 is created.

Can someone point me in the right direction to get started here?

Notes:
* CRM Rollup 2 have been applied.

* The CRM user that owns the workflow has a CRM System Administrator
role and the "Restricted Access Mode" property is not checked. That
same user manually applied the rule and completed Task 1.

* The Microsoft CRM Workflow Service is running, as our Domain
administrator.
 
 
 

Workflow : Wait activity condition does not work

Post by YmxpdHRsZU » Sun, 27 Jan 2008 02:20:02



 
 
 

Workflow : Wait activity condition does not work

Post by YmxpdHRsZU » Sun, 27 Jan 2008 02:22:09

We had the same problem and changed the account that runs CRM Workflow
Service to NT AUTHORITY\NETWORK SERVICE and it started working. I don't think
this is the real fix for this, but is a work around. Still trying to
research.