Error when upgrading CRM 3.0 to CRM 4.0

Error when upgrading CRM 3.0 to CRM 4.0

Post by bHVhaT » Fri, 23 May 2008 04:40:13


I have a CRM3.0 Pro that has been working fine for the last 2 years...
We decided to upgrade it to CRM4.0, so I decided to install the whole stuff
on a test
machine. So I restored the latest backup from CRM3.0 SQL database on this
test machine and installed CRM3.0 and it is working perfectly all right with
all its customizations on the test machine.

Then when installing CRM4.0 on this test machine as an upgrade for CRM 3.0
and in the middle of the installation in the stage: "Creating and configuring
Microsoft DynamicsCRM groups in Active Directory" I got an error:

Action Microsoft.Crm.Setup.CreateCrmGroupsAction failed.
The server is unwilling to process the request. (Exception from
HRESULT:0x80072035)

and I am only given 2 options: "Retry" or "Cancel"... Retry: gives the same
result and Cancel: aborts installtion and leaves CRM in an unworking state
where I have to uninstall CRM4.0 then reinstall CRM 3.0 again and so on....


Any help is highly appreciated.

- I am logged on with a user who is an admin on both the domain-controller
and the local machine
- I am working on Windows 2003 SP2
- I am using SQL Server 2005 SP2
 
 
 

Error when upgrading CRM 3.0 to CRM 4.0

Post by SW5kaXJhIE » Sat, 24 May 2008 04:56:01

You are running into issue where installing user does not have right to
create a group within OU.

http://www.yqcomputer.com/
3) b. Must be able to create a security group within the OU where the 4 3.0
groups exist

There is hotfix for the issue soon to be released, with this hotfix you will
get EDW warning.

One workaround is to give yourself right to create all child objects in OU.
Another workaround is to use pre-existing groups and specify groups in setup
config.xml file
<?xml version="1.0" encoding="utf-8"?>
<CRMSetup>
<Server>
<Groups autogroupmanagementoff="false">

<PrivReportingGroup>CN=GroupName,OU=OUName,DC=DCName,DC=DCName,DC=DCName,DC=DCName</PrivReportingGroup>
</Groups>
</Server>
</CRMSetup>

Thanks,
Indira Dhingra [MSFT]

 
 
 

Error when upgrading CRM 3.0 to CRM 4.0

Post by bHVhaT » Sat, 24 May 2008 20:40:01

hanks a lot for the help,

In fact after checking the installation log I found the following error:

21:03:56| Info| Executing Install action:
Microsoft.Crm.Setup.Server.CreateCrmGroupsAction
21:03:57|Verbose| Creating group PrivReportingGroup
{70ba4bb2-895a-42b0-924b-56612e4ec799} ...
21:03:57| Error| System.Exception: Action
Microsoft.Crm.Setup.Server.CreateCrmGroupsAction failed. --->
System.DirectoryServices.DirectoryServicesCOMException (0x80072035): The
server is unwilling to process the request. (Exception from HRESULT:
0x80072035)
at System.DirectoryServices.DirectoryEntry.CommitChanges()
at
Microsoft.Crm.Setup.Server.Utility.ADUtility.CreateCrmGroup(DirectoryEntry
container, String prefix, Guid guid)
at Microsoft.Crm.Setup.Server.CreateCrmGroupsAction.Do(IDictionary
parameters)
at Microsoft.Crm.Setup.Common.Action.ExecuteAction(Action action,
IDictionary parameters, Boolean undo)
--- End of inner exception stack trace ---, Error, RetryCancel, Option1


So after doing further research I found the following article:

http://support.microsoft.com/kb/946677

I followed the istructions for "Installation option 1" and all went fine :-))

I just wish that Microsoft CRM4 Installation Wizzard displays
a warning prior to going into the actual installtion... because
once this error appears there is no going back and you have
to re-do everything again including reinstallting CRM 3.0 !!!!

I wasted 2 full days on this issue !!!!!!!!


"Indira Dhingra [MSFT]" wrote: