Bug Report - 2 Bugs found with the Menu Item Class

Bug Report - 2 Bugs found with the Menu Item Class

Post by QmFnZ3 » Fri, 20 Feb 2004 03:31:07


I have found 2 bugs with the menu item class; both are closely related

Over-View

I was curious what would happen if I passed a menu item the following string in it's text field
"Test &&&me &1 &&&2

Yes I know this is BAD programming, but it is how you find out what works

[Bug 1 - Hot Key Parsing
With the above string the "2" is highlighted, while the "m" remains the hot key. The hot key and the underlined key need to match each other

[Bug 2 Hot Key Enabling with UserDraw = true
With the above string, if UserDraw is set to true before the MenuItem is added to the MainMenu the hot key will not work. However, if you wait till after the MenuItem, has been added to the MainMenu, then set UserDraw = true, the hot key will function correctly

If you whish to see my code, ask; Il email it directly to you, as I was trying to make a simple custom MenuItem when I discovered this

Bagg
 
 
 

Bug Report - 2 Bugs found with the Menu Item Class

Post by QmFnZ3 » Fri, 20 Feb 2004 03:46:05

There is an error in the above post

The string I passed looked lik
"Test &me &1 &&&2

Incase it is parsed by the server when I send it in here is what it was

Tes
Spac
Ampersan
m
Spac
Ampersan
On
Spac
Ampersan
Ampersan
Spac
Ampersan
Tw

 
 
 

Bug Report - 2 Bugs found with the Menu Item Class

Post by Vijay Deva » Sun, 22 Feb 2004 03:25:11

I'd like to see your code - could you send it to me? You'll need to remove
the "online" in my email address. Thanks,
Vijay

--
--
Please reply in newsgroup.
This posting is provided "AS IS" with no warranties, and confers no rights.

"Use of included script samples are subject to the terms specified at
http://www.yqcomputer.com/ "