Delayed User Account Control

Delayed User Account Control

Post by TmV4dV » Wed, 06 Aug 2008 07:48:01


Usually, it takes a second or less for User Account Control to switch over to
the secure desktop and the same amount of time for it to switch back.
However, whenever I need to provide permission on my computer, the screen
will black out for 3-5 seconds, I get the UAC prompt, and after providing
permission, the screen blacks out again for another 3-5 seconds before
returning to my normal desktop. I honestly have no problem with UAC, but this
unusual delay in brining up the prompt is extremely irritating. On enabling
my computer's guest account, I discovered that the UAC prompt functions
normally on the that account. It is only on my account that it acts slowly.
Any ideas what might be causing this delay? I've spend ages browsing forum
after forum and am still unable to find a solution.
 
 
 

Delayed User Account Control

Post by TmV4dV » Thu, 07 Aug 2008 00:58:01

I've played around with disabling the secure desktop. But in truth, making my
computer more vulnerable to malware isn't very high on my priority list. I
would rather simply figure out what might be causing the delay rather than
disabling the secure desktop.

And in fact, yes, this delay occurs every time I get the UAC prompt. I at
first suspected that it might have something to do with lack of available
system resources, but I don't believe that is the case seeing as how the
delay times are very consistent with each other.

 
 
 

Delayed User Account Control

Post by Victor Con » Thu, 07 Aug 2008 18:53:41

Hi,
What are your computer specs? (Proccessor, RAM, Graphics memory)

--
Victor Constantinescu aka YounGun
Security MVP
http://www.yqcomputer.com/
 
 
 

Delayed User Account Control

Post by TmV4dV » Fri, 08 Aug 2008 01:05:00

HP Pavilion dv9008nr
AMD Turion 64 X2 TL-50 1.6 GHz (per core)
2.00 GB RAM
NVIDIA GeForce Go 6150 (32 MB adapter RAM, 521 MB shared RAM)

Let me know if you require any additional information.
 
 
 

Delayed User Account Control

Post by VmljdG9yIE » Sat, 09 Aug 2008 19:42:00

Hi,
That's a decent configuration. Are you running any memory intesive programs?
Right-click Computer > Properties > Advanced system settings > under
performance, click advanced > select adjust for best performance.
 
 
 

Delayed User Account Control

Post by TmV4dV » Sun, 10 Aug 2008 05:23:00

Thank you so much for all your help! Upon investigation, I discovered that
the Aero settings were causing the delay. Not wanting to sacrifice the visual
superiority of Aero, I uninstalled and reinstalled my display drivers, and
that resolved the problem.