ASP Error Message, ASP 0113

ASP Error Message, ASP 0113

Post by NeeLyn206 » Sat, 24 Jul 2004 01:06:46


Just want to post a quick fix to a problem we were having just in case it is
not just us.
About three weeks ago, we suddenly starting getting errors on your ASP
pages. We are using IIS 6 and Microsoft Access databases. The error message
was
"Active Server Pages, ASP 0113 (0x80004005)
The maximum amount of time for a script to execute was exceeded. You can
change this limit by..."
We checked our server settings and they were already set higher then what
Microsoft was recommending to fix the error. However, on further investigation
we found that our earliest ASP pages that were developed in Dreamweaver 3 or 4
were missing the second line of code in closing the database connections. The
old closers looked like this:
<%
Recordset1.Close()
%>
They should be
<%
Recordset1.Close()
Set Recordset1 = Nothing
%>
Once we added the second line of code to our old pages all seems well with the
world.

Hope this helps someone!
 
 
 

ASP Error Message, ASP 0113

Post by Murray *TM » Sat, 24 Jul 2004 01:17:22

DW 3 and DW 4 did not do ASP coding, so you must have done this manually.
UltraDev was the first of the "DW" programs to write ASP code for you.

When I look back at sites I did in UD (I'm not sure which version, however),
I see that corrected code already there.

--
Murray --- ICQ 71997575
Team Macromedia Volunteer for Dreamweaver
(If you *MUST* email me, don't LAUGH when you do so!)
==================
http://www.yqcomputer.com/ - Template Triage!
http://www.yqcomputer.com/ , Tutorials & Resources
http://www.yqcomputer.com/ - DW FAQs, Tutorials & Resources
http://www.yqcomputer.com/ (MM) Technotes
==================



is
message
investigation
or 4
The
with the

 
 
 

ASP Error Message, ASP 0113

Post by Les Matthe » Sat, 24 Jul 2004 02:13:39

UD did not "destroy" recordsets by settting to nothing. When I have opened
an old UD-coded ASP file in MX, there has been an icon by the recordset in
server behaviors panel indicating a problem with it. Opening the recordset
and saving, places the "Set ... = Nothing" line.



however),


it
ASP
can
what
3
connections.
 
 
 

ASP Error Message, ASP 0113

Post by Murray *TM » Sat, 24 Jul 2004 04:50:10

don't follow. So you are saying that UD did not put the

Set Recordset1 = Nothing

code there? It did in my sites.

--
Murray --- ICQ 71997575
Team Macromedia Volunteer for Dreamweaver
(If you *MUST* email me, don't LAUGH when you do so!)
==================
http://www.dreamweavermx-templates.com - Template Triage!
http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
http://www.dwfaq.com - DW FAQs, Tutorials & Resources
http://www.macromedia.com/support/search/ - Macromedia (MM) Technotes
==================

"Les Matthews" < XXXX@XXXXX.COM > wrote in message
news:cdosk4$edc$ XXXX@XXXXX.COM ...
manually.
Dreamweaver


 
 
 

ASP Error Message, ASP 0113

Post by D. Shane F » Sat, 24 Jul 2004 04:59:23

think with my original version of UD4, it lacked these RS killers too.
Perhaps an Updater fixed it at some point.

--


**************************************************
D. Shane Fowlkes
Web Applications Manager
Easter Associates, Inc.
1011 East Main Street
Suite 220
Richmond, VA 23219
(804) 643-4433
Fax: (804) 643-1033
XXXX@XXXXX.COM
**************************************************


"Murray *TMM*" < XXXX@XXXXX.COM > wrote in message
news:cdp5ph$pji$ XXXX@XXXXX.COM ...
opened
in
recordset
case
your
error
You
then
well


 
 
 

ASP Error Message, ASP 0113

Post by Murray *TM » Sat, 24 Jul 2004 05:12:42

dunno....

--
Murray --- ICQ 71997575
Team Macromedia Volunteer for Dreamweaver
(If you *MUST* email me, don't LAUGH when you do so!)
==================
http://www.dreamweavermx-templates.com - Template Triage!
http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
http://www.dwfaq.com - DW FAQs, Tutorials & Resources
http://www.macromedia.com/support/search/ - Macromedia (MM) Technotes
==================

"D. Shane Fowlkes" < XXXX@XXXXX.COM > wrote in message
news:cdp6b7$q5q$ XXXX@XXXXX.COM ...
recordset
you.
Technotes


 
 
 

ASP Error Message, ASP 0113

Post by Les Matthe » Sat, 24 Jul 2004 07:17:49

es, my recollection is that line was not created by UD generated
recordsets. I didn't see it until MX.

"Murray *TMM*" < XXXX@XXXXX.COM > wrote in message
news:cdp5ph$pji$ XXXX@XXXXX.COM ...
opened
in
recordset
case
your
error
You
then
well


 
 
 

ASP Error Message, ASP 0113

Post by Murray *TM » Sat, 24 Jul 2004 07:22:44

es:

Frankly, I am not sure....

--
Murray --- ICQ 71997575
Team Macromedia Volunteer for Dreamweaver
(If you *MUST* email me, don't LAUGH when you do so!)
==================
http://www.dreamweavermx-templates.com - Template Triage!
http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
http://www.dwfaq.com - DW FAQs, Tutorials & Resources
http://www.macromedia.com/support/search/ - Macromedia (MM) Technotes
==================

"Les Matthews" < XXXX@XXXXX.COM > wrote in message
news:cdpeed$698$ XXXX@XXXXX.COM ...
recordset
you.
Technotes