Problem with downloading ActiveX control in IE 6 SP1

Problem with downloading ActiveX control in IE 6 SP1

Post by fnile » Sat, 07 Jan 2006 01:21:33


We created an ActiveX control and marked it as safe for scripting using
Implements IObjectSafety. We then created a CAB file and signed it using
Verisign.
We also created a license file (LPK file) for it.
We use this control on an ASP page.
We put the CAB file for the AX control and VBRun60.CAB in the same folder
with all the ASP files.
When we call the ASP page using any machine with IE 6 SP2 (we tried it with
multiple IE6 SP2 machines), it prompted you to download the control and it
got downloaded fine, and the ASP page works fine.
But, when we call the ASP page using a machine with IE 6 SP1 (we tried it
with multiple IE6 SP1 machines), it did not even prompt you to download the
control even though the control does not exist in the machine. Because of
this, the ASP page does not work because the AX control does not exist.
The IE setting is such that we either enable or prompt downloading a control
and initialize and script AX control.

Here is the codes for the control in the ASP page:
<OBJECT CLASSID="clsid:5220cb21-c88d-11cf-b347-00aa00a28331"
id="Microsoft_Licensed_Class_Manager_1_0"1 VIEWASTEXT><PARAM
NAME="LPKPath" VALUE="BControl.lpk"></OBJECT>

<OBJECT id="bcontrol2" height=0 width=0
classid=clsid:CAC161FD-C2F9-4F0F-95F3-A3D4E5D465CD
codeBase="BControl.CAB#version=1,0,0,0" VIEWASTEXT>
<PARAM NAME="_ExtentX" VALUE="873">
<PARAM NAME="_ExtentY" VALUE="847">
</OBJECT>

Why in IE 6 SP1 it did not even prompt me to download the AX control even
though it does not exist?

Thank you very much.
 
 
 

Problem with downloading ActiveX control in IE 6 SP1

Post by fnile » Sat, 07 Jan 2006 01:46:31

More information:
the problem with downloading the AX control in IE6 SP1 is with Win2000
machines (IE6 SP2 is on WinXP machine, and it is fine).
Is it possible that with Win2000 machine one is prohibited from downloading
ActiveX control ?
How can we get around it ?

Thank you.

 
 
 

Problem with downloading ActiveX control in IE 6 SP1

Post by PA Bea » Sat, 07 Jan 2006 03:00:17

Are all of the affected machines fully up-to-date at Windows Update?

ActiveX controls may not load as expected in Internet Explorer due to
defense in depth changes introduced in cumulative security update 896688
(MS05-052)
http://www.yqcomputer.com/

A Web page that contains a custom ActiveX control may not load as expected
in Internet Explorer due to defense in depth changes introduced in
cumulative security update 896688 (MS05-052)
http://www.yqcomputer.com/

The fix detailed in 909889 involving the Registry and OLE32.DLL is available
at

- http://www.yqcomputer.com/ , and

- http://www.yqcomputer.com/ (a small VB app that
checks the 4 values and offers a repair option if any of them are
incorrect).
--
~Robear Dyer (PA Bear)
MS MVP-Windows (IE/OE, Shell/User, Security), Aumha.org VSOP, DTS-L.org
 
 
 

Problem with downloading ActiveX control in IE 6 SP1

Post by fnile » Sat, 07 Jan 2006 04:27:14

Thanks a lot for your help.

Yes, yesterday we installed all the Windows update for Win2000 SP4.

We ran the http://www.yqcomputer.com/ , and it says
that all 4 values are correct.

What else do we need to check ?

Thanks.
 
 
 

Problem with downloading ActiveX control in IE 6 SP1

Post by PA Bea » Sat, 07 Jan 2006 07:47:36

id you reboot?

fniles wrote:

 
 
 

Problem with downloading ActiveX control in IE 6 SP1

Post by fnile » Sat, 07 Jan 2006 23:15:51

gt; Did you reboot?
Did you mean after we install all the Windows update, did we reboot?
Yes, we did.


"PA Bear" < XXXX@XXXXX.COM > wrote in message
news: XXXX@XXXXX.COM ...