when the text is null ,the datefield does not work

when the text is null ,the datefield does not work

Post by leilingden » Fri, 25 Jul 2008 21:11:37


when i click the dateField,the datePannel throws a exception.
i guess the reason is that the component's text propertiy is null.
and textinput which id is 'aaaa' shwo "NaN".
somebody help me ,thanks

<?xml version="1.0" encoding="utf-8"?>
<mx:Application xmlns:mx=" http://www.yqcomputer.com/ " layout="absolute"
creationComplete="initModule();">
<mx:Script>
<![CDATA[

import mapping.Module;
[Bindable]
public var module:Module = new Module();
[Bindable]
public var map:Object = new Object();
public function initModule():void{
module.sm_id="aaaaaa";

}

]]>
</mx:Script>
<mx:DateFormatter id="fmt" formatString="YYYY-MM-DD"/>
<mx:HBox x="114" y="54" width="475" height="306">
<mx:VBox height="100%" width="212">
<mx:Label text="sm_id" height="25"/>
<mx:Label text="sm_name" height="25"/>
<mx:Label text="sm_type" height="25"/>
<mx:Label text="dddd" height="25"/>
<mx:Label text="aaaa" height="25"/>
</mx:VBox>
<mx:VBox height="100%" width="252">
<mx:TextInput text="{module.sm_id}"/>
<mx:TextInput text="{module.sm_name}"/>
<mx:TextInput text="{module.sm_type}"/>
<mx:DateField text="{module.dddd}"/>
<mx:TextInput text="{module.aaaa}"/>
</mx:VBox>
</mx:HBox>

</mx:Application>
 
 
 

1. Is Null/Is Not Null only options when doing a Filter

2. Query in VB will not work..What am I doing wrong?

So..I have the following query in access:

SELECT Check_In.ID, Check_In.[Product Name], Check_In.[S/N], Check_In.[Part #]
, Check_In.[Date Receive], Check_In.[UPS Tracking#], Check_In.[DTAC Case],
Check_In.[Dealer Acct #], Check_In.Dealer, Check_In.[Claim# 1], Check_In.
[Claim# 2], Check_In.[Entered to FPRT (Y/N)], Check_In.Comments, Check_In.
[Date Entered to FPRT], Check_In.[Geographical Location (Ship From)]
FROM Check_In
WHERE ((([Check_in].[S/N])=[Enter Serial Number]));

I'm trying to get this to work in my VB project. I have all my database
linked, data grid view in my form and tested the connection..all work fine.
WITHOUT building a query in VB, I can debug and all the information from the
is there.

When I try to create a query based off of the data in the data grid, this is
where I'm running into problems.

Why would the SQL that works in my access badatbase not work in my vb project?


--
Message posted via AccessMonster.com
http://www.yqcomputer.com/

3. AVG(COUNT(timestamp))...this will not work, what am I doing wrong?

4. Cisco 837 NAT not working, what am I doing wrong?

5. KeyEvent consume() not working on JTextField, what am I done wrong?

6. Custom sharepoint search does not work : what am I doing wrong?

7. .NET Assembly works, but not via Workflow...What am I doing wr

8. Is Not Null is not working on a text field?

9. AVG(COUNT(timestamp))...this will not work, what am I doing wrong

10. Key events work in Netscape and IE, but not Firefox - what am I doing wrong

11. KeyEvent consume() not working on JTextField, what am I doing wrong?

12. table_info not working, am I doing something wrong?

13. A trivial problem with Tk, I am sure I am not doing it the right way

14. user.IsApproved = false; is NOT working, what am I doing wrong????