Source Code Formatter

Source Code Formatter

Post by Terry Haa » Tue, 10 Oct 2006 04:34:23


I am interested a source code formatter for a large project. In addition to
fixing up all the formatting (spacing, indents, etc) I am also looking for a
tool to reorganize the source files such as sorting the class definition
alphabetically, organize a class's methods in the same order as the
definitions, etc.

Does anything like this exist ?

Thanks,
Terry.
 
 
 

Source Code Formatter

Post by Charles Mc » Tue, 10 Oct 2006 06:21:35


for source formatting there's DelForExp...
http://www.yqcomputer.com/

and Jedi Code Format...
http://www.yqcomputer.com/

for sorting classes and methods i highly recommend ModelMaker...
http://www.yqcomputer.com/

 
 
 

Source Code Formatter

Post by matthe » Tue, 10 Oct 2006 19:58:00

> for sorting classes and methods i highly recommend ModelMaker...

The Code Explorer will do this, and was the reason I bought it years ago.
Since then it has expanded in use for me.

/Matthew Jones/
 
 
 

Source Code Formatter

Post by matthe » Tue, 10 Oct 2006 19:58:00

> for sorting classes and methods i highly recommend ModelMaker...

The Code Explorer will do this, and was the reason I bought it years ago.
Since then it has expanded in use for me.

/Matthew Jones/
 
 
 

Source Code Formatter

Post by Thomas Mue » Fri, 13 Oct 2006 02:46:56

Hi Terry,




The DelForEx formatter is also available as part of an experimental version
of GExperts from my homepage
http://www.yqcomputer.com/ #a2006-05-01

MfG
twm
 
 
 

Source Code Formatter

Post by Ken Randal » Fri, 13 Oct 2006 03:17:00

Is there an english version?
 
 
 

Source Code Formatter

Post by Kevin Powi » Fri, 13 Oct 2006 09:09:18


The download link found on the above page

http://www.yqcomputer.com/
06-05-01.zip

does not download the zip file, but takes you to a dutch language page
of some sort.



--
Kevin Powick
 
 
 

Source Code Formatter

Post by Thomas Mue » Fri, 13 Oct 2006 16:34:52

Hi Ken,





An English version of what? GExperts is in English and the page I linked
also is in English, so what are you missing?

MfG
twm
 
 
 

Source Code Formatter

Post by Jerry Haye » Fri, 13 Oct 2006 17:42:39

> An English version of what? GExperts is in English and the page I linked

Just an FYI, the link you provided is a link to a description of a download.
When you click on the "experimental version..." link to get the file, takes
you to a 404 error in German.

HTH.
 
 
 

Source Code Formatter

Post by G.W. van d » Fri, 13 Oct 2006 17:57:34

Hi Thomas

Do you have a more recent build than may 2006?

I still get the occasional error message and a letter 'd' inserted into the
sources afterwards.

--
Wim van der Vegt
 
 
 

Source Code Formatter

Post by Thomas Mue » Fri, 13 Oct 2006 18:41:16

Hi Jerry,





Thanks for telling me, I had not noticed that problem. I made a mistake
there but there also seems to be a bug in webmake because even after fixing
the problem the created html is still wrong. :-(
I'll dig into this, but it will take a while.

In the meantime please use this link for downloading the zip file:

http://www.yqcomputer.com/

MfG
twm
 
 
 

Source Code Formatter

Post by Thomas Mue » Fri, 13 Oct 2006 18:50:54

Hi Wim,





Not yet, but I'll try to do one this weekend. I can't promise anything
though, neither that I will do it nor that it will fix any problems. I
currently have no working installation of Delphi 7 and Delphi 2005, so it
will take some time to set it up.

MfG
twm
 
 
 

Source Code Formatter

Post by Thomas Mue » Fri, 13 Oct 2006 18:52:10

Hi,




It wasn't webmake's fault after all but all just my own stupidity. Should be
fixed now.

MfG
twm
 
 
 

Source Code Formatter

Post by G.W. van d » Sat, 14 Oct 2006 21:19:15

Hi Thomas,

Got the cvs version working. If you can give me some pointers of how to
debug the thingy (i.e. where to look)
I might try to trace back some of the errors myself and mail them to you.

--
Wim van der Vegt
 
 
 

Source Code Formatter

Post by Thomas Mue » Sun, 15 Oct 2006 20:03:35

Hi Wim,




That's exactly my problem: I don't know what causes these problems and don't
know where to look. You might start with searching the GExperts code for
the error message containing "the target of an invocation" and go from
there, but I am afraid that won't help you much.


You are welcome to do that.

MfG
twm