Migrating from Firebird 1.5 to Firebird 2.0 (connection issues)

Migrating from Firebird 1.5 to Firebird 2.0 (connection issues)

Post by DaviWal » Fri, 09 Mar 2007 04:18:00


Very simple test.

I performed a backup of my dabatase using FB 1.5 through IBExpert v.
2005.04.24.

After installed FB 2.0 then I performed the restore with no problems.
Then Database wasn't connecting.
So, I figured out that I needed to restart the service, so the
database with the new ODS 11 started to work.

No big problems so far.

NOW! I was performing some tests and I found that I can't open more
than 1 connection to the database. So, lets say, I created a
connection to my database using IBExpert, double click on it, boom!
connected.
NOW Open another IBExpert (the connection is already configured at
this time),
double click on it, BOOM! error message.

"Unsucessfully execution caused by a system error that precludes
succesful......"
" Database XXXXX shutdown "

This issue never happened in FB 1.5

Anyone has any idea how to solve this problem ?

Ty in advance...

Davi Wall
 
 
 

Migrating from Firebird 1.5 to Firebird 2.0 (connection issues)

Post by DaviWal » Fri, 09 Mar 2007 04:34:10


Performing some more tests, I've discovered that when I create a new
database in FB 2.0 this problem mentioned above doesnt happen.

 
 
 

Migrating from Firebird 1.5 to Firebird 2.0 (connection issues)

Post by Thomas Ste » Fri, 09 Mar 2007 15:49:41


As the error message states, your database is in shutdown mode. Either
use gfix to bring it back online again or IBExpert might be able to do
that via ServicesAPI as well.


--
Best Regards,
Thomas Steinmaurer
LogManager Series - Logging/Auditing Suites supporting
InterBase, Firebird, Advantage Database, MS SQL Server and
NexusDB V2
Upscene Productions
http://www.yqcomputer.com/