expat

expat

Post by Jeff Kis » Fri, 09 Dec 2005 04:41:35


Hello.
I am trying to get expat to build under borland 5.02 (unless there is
a better option)?

I had to get rid of a bunch of build options (-q, -Gn, etc) before it
would get anywhere, and now I see

Error: Unable to open file 'C0D32W.OBJ'

I assume this is a Cbuilder obj and was hoping there was a borland
5.02 compatible version to replace it with.

Thanks
Jeff
p.s. session in dos shell below with full text of problem from
console screen:



C:\Downloads\XML\expat\expat-1.95.8\bcb5>c:\bc5\bin\make
MAKE Version 5.0 Copyright (c) 1987, 1997 Borland International
setup

C:\Downloads\XML\expat\expat-1.95.8\bcb5>REM CommandInterpreter:
$(COMSPEC)

C:\Downloads\XML\expat\expat-1.95.8\bcb5>if not exist .\release\nul
mkdir release

C:\Downloads\XML\expat\expat-1.95.8\bcb5>if not exist
.\release\obj\nul mkdir release\obj

C:\Downloads\XML\expat\expat-1.95.8\bcb5>if not exist
.\release\obj\libexpat\nul mkdir release\obj\libexpat

C:\Downloads\XML\expat\expat-1.95.8\bcb5>if not exist
.\release\obj\libexpatw\nul mkdir release\obj\libexpatw

C:\Downloads\XML\expat\expat-1.95.8\bcb5>if not exist
.\release\obj\libexpat_static\nul mkdir release\obj\libexpat_stati
c

C:\Downloads\XML\expat\expat-1.95.8\bcb5>if not exist
.\release\obj\libexpatw_static\nul mkdir release\obj\libexpatw_sta
tic

C:\Downloads\XML\expat\expat-1.95.8\bcb5>if not exist
.\release\obj\examples\nul mkdir release\obj\examples

C:\Downloads\XML\expat\expat-1.95.8\bcb5>if not exist
.\release\obj\xmlwf\nul mkdir release\obj\xmlwf
make -l -fexpat.mak
MAKE Version 5.2 Copyright (c) 1987, 2000 Borland
make -l -fexpatw.mak
MAKE Version 5.2 Copyright (c) 1987, 2000 Borland
c:\bc5\BIN\ilink32 @MAKE0000.@@@
Turbo Incremental Link Version 1.0 Copyright (c) 1997 Borland
International
Error: Unable to open file 'C0D32W.OBJ'

** error 2 ** deleting Release\libexpatw_mtd.dll

** error 1 ** deleting expatw

C:\Downloads\XML\expat\expat-1.95.8\bcb5>
Jeff Kish
 
 
 

expat

Post by Regis St-G » Fri, 09 Dec 2005 09:42:20


XXXX@XXXXX.COM ...

Jeff,

I am using expat but I compile with the free version of builder 5.5
My setup is as follow:
Borland C++ 5.02 for the IDE
Free command line compiler (builder 5.5)
Tools 55 to integrate the compiler into the Borland C++ 5.02 IDE

I think that the build files that comes with expat are for Builder only.
Either you switch to the 5.5 compiler. (less bug than the 5.02 compiler)
or you find a way to compile expat with borland 5.02

Maybe you could try asking this on the Expat list.
You can subscribe at:
http://www.yqcomputer.com/

I switched to the 5.5 compiler when I migrated my applications to OwlNext.
You can find references for Tools 55 and also for OWlNext on Jogy's web site
http://www.yqcomputer.com/
in the "Borland C++ 5.0 Add-ons" section

Hope this helps.

Best Regards,

--
Regis St-Gelais
www.laubrass.com

 
 
 

expat

Post by Jeff Kis » Fri, 09 Dec 2005 19:55:31

<snip>
thanks. I'll check it out.
Unfortunately not an option for me (to change compilers)

Regards
.
 
 
 

expat

Post by Bob Gonde » Sat, 10 Dec 2005 00:01:04


The C-zero files are startup files.
Try replacing it with the startup file of your choice (depends on the
target exe type)