Azureus ... forced to use Windows Version ...

Azureus ... forced to use Windows Version ...

Post by scrapp » Tue, 02 May 2006 11:40:23



The other day, I posted about download issues with Azureus ... today,
figuring to see if it was my network, or FreeBSD, I installed it on one of
my Windows boxes, and am currently downloading at ~85kb/s ;(

Please note that this Windows box is sitting *behind* the same FreeBSD box
that I'm lucky to get 1kb/s on ... the FreeBSD is the router ...

I don't know if this is a java issue, or freebsd issue ... but I really
don't have any ideas on how to debug why ...

Other then the machine its running on, I have Azureus setup the same,
including using java 1.5.0 ... but, of course, the version on the FreeBSD
is the new diablo binary ...

thoughts?

----
Marc G. Fournier Hub.Org Networking Services ( http://www.yqcomputer.com/ )
Email: XXXX@XXXXX.COM Yahoo!: yscrappy ICQ: 7615664
_______________________________________________
XXXX@XXXXX.COM mailing list
http://www.yqcomputer.com/
To unsubscribe, send any mail to " XXXX@XXXXX.COM "
 
 
 

Azureus ... forced to use Windows Version ...

Post by arte » Tue, 02 May 2006 17:17:06

Marc G. Fournier:

I don't know about the current diablo-jdk build, but on
/usr/ports/java/jdk15/ i had very bad threads performance with threads
locked up and waiting for nothing, until i recompiled the FreeBSD with
"options SMP" turned on. It was on an architecture similar to yours:
"CPU: Intel(R) Pentium(R) 4 CPU 2.80GHz (2793.01-MHz 686-class CPU)"
Perhaps the threading library used with jdk has some inference with the
kernel scheduler or something. If your FreeBSD is build without SMP,
this might be the problem.
_______________________________________________
XXXX@XXXXX.COM mailing list
http://www.yqcomputer.com/
To unsubscribe, send any mail to " XXXX@XXXXX.COM "

 
 
 

Azureus ... forced to use Windows Version ...

Post by sugimur » Tue, 02 May 2006 19:48:40

> Other then the machine its running on, I have Azureus setup the same,

Please add the follows to /etc/libmap.conf and try again.

#######################################################
[/usr/local/diablo-jdk1.5.0/]
libpthread.so libc_r.so
libpthread.so.2 libc_r.so.6

---
SUGIMURA Takashi < XXXX@XXXXX.COM >
GnuPG fingerprint: C81B 9835 1C9E BD9B 84BF 9785 0B91 D08B F667 DCED
_______________________________________________
XXXX@XXXXX.COM mailing list
http://www.yqcomputer.com/
To unsubscribe, send any mail to " XXXX@XXXXX.COM "
 
 
 

Azureus ... forced to use Windows Version ...

Post by scrapp » Wed, 03 May 2006 02:16:53


Woo hoo ... that fixes it ... stupid question, but *why*? If this was
originally built on a 6.x machine, why is the mapping required?

And ... could someone maybe add a note to the download page itself? :( I
just re-checked the downloads page, and there is nothing there about it
...





----
Marc G. Fournier Hub.Org Networking Services ( http://www.yqcomputer.com/ )
Email: XXXX@XXXXX.COM Yahoo!: yscrappy ICQ: 7615664
_______________________________________________
XXXX@XXXXX.COM mailing list
http://www.yqcomputer.com/
To unsubscribe, send any mail to " XXXX@XXXXX.COM "
 
 
 

Azureus ... forced to use Windows Version ...

Post by glewi » Wed, 03 May 2006 05:21:14


It shouldn't be.


One thing I'm curious about is whether anyone sees the same problem under
6.0-RELEASE?



--
Greg Lewis Email : XXXX@XXXXX.COM
Eyes Beyond Web : http://www.yqcomputer.com/
Information Technology FreeBSD : XXXX@XXXXX.COM
_______________________________________________
XXXX@XXXXX.COM mailing list
http://www.yqcomputer.com/
To unsubscribe, send any mail to " XXXX@XXXXX.COM "