How to install JDK 1.4 on FreeBSD 5.4

How to install JDK 1.4 on FreeBSD 5.4

Post by madru » Fri, 22 Jul 2005 13:32:05


Sorry, i am newbie in Java FreeBSD,
I don't understand how to install JDK 1.4 on FreeBSD 5.4,
any body can help me ??? i try to install like Linux Installation
but for Serial Communication still problem.
Error message like this:
-------------------------------
Exception in thread "main" java.lang.UnsatisfiedLinkError: deviceOpen
at org.freebsd.io.comm.FreebsdSerial.deviceOpen(Native Method)
at org.freebsd.io.comm.FreebsdSerial.<init>(FreebsdSerial.java:115)
at org.freebsd.io.comm.FreebsdDriver.getCommPort
(FreebsdDriver.java:111)
at javax.comm.CommPortIdentifier.open(CommPortIdentifier.java:627)
at SerialModule.initConnection(SerialModule.java:86)
at SerialThread.<init>(SerialThread.java:23)
at GSerialPro.main(GSerialPro.java:35)
--------------------------------
Thanks before.

Said Madrus
Java FreeBSD Newbie


_______________________________________________
XXXX@XXXXX.COM mailing list
http://www.yqcomputer.com/
To unsubscribe, send any mail to " XXXX@XXXXX.COM "
 
 
 

How to install JDK 1.4 on FreeBSD 5.4

Post by jonc » Fri, 22 Jul 2005 15:11:55


Basically:

# cd /usr/ports/java/jdk14
# make install

It will stop a couple of times with things that you need to do. Read
the instructions and follow them. If you have a problem, then ask us
providing *EXACT* details and screen output.

Cheers.
--
Jonathan Chen < XXXX@XXXXX.COM >
----------------------------------------------------------------------
"If everything's under control, you're going too slow"
- Mario Andretti
_______________________________________________
XXXX@XXXXX.COM mailing list
http://www.yqcomputer.com/
To unsubscribe, send any mail to " XXXX@XXXXX.COM "

 
 
 

How to install JDK 1.4 on FreeBSD 5.4

Post by achil » Fri, 22 Jul 2005 16:08:15

O XXXX@XXXXX.COM Jul 21, 2005 :


So you installed javacomms???

Try to
1) install jdk14 from ports like other people have told you
2)
# cd /usr/ports/comms/java-commapi-freebsd/
# make install

In contrast to Linux, FreeBSD native JavaComms work like a charm.

Let us know the outcome of your effort.



--
-Achilleus

_______________________________________________
XXXX@XXXXX.COM mailing list
http://www.yqcomputer.com/
To unsubscribe, send any mail to " XXXX@XXXXX.COM "
 
 
 

How to install JDK 1.4 on FreeBSD 5.4

Post by madru » Fri, 22 Jul 2005 23:16:51

Thanks to all Java-FreeBSD Miliser,
I will try all of your sugestion.

Said Madrus


________________ Original message ________________
Subject: Re: How to install JDK 1.4 on FreeBSD 5.4
Author: "Jonathan Chen" < XXXX@XXXXX.COM >
Date: 21st July 2005 6:11:29=20



Basically:

# cd /usr/ports/java/jdk14
# make install

It will stop a couple of times with things that you need to do. Read
the instructions and follow them. If you have a problem, then ask us
providing *EXACT* details and screen output.

Cheers.
--=20
Jonathan Chen < XXXX@XXXXX.COM >
_______________________________________________
XXXX@XXXXX.COM mailing list
http://www.yqcomputer.com/
To unsubscribe, send any mail to " XXXX@XXXXX.COM "
 
 
 

How to install JDK 1.4 on FreeBSD 5.4

Post by madru » Mon, 25 Jul 2005 17:26:16

Dear miliser,
I still get problem when installing java port on FreeBSD.
The Error message like this:
------------------
/usr/local/jdk1.4.2/include/jni.h:27:20: jni_md.h: No such file or
directory
In file included from src/org/freebsd/io/comm/libSerial.c:32:
/usr/local/jdk1.4.2/include/jni.h:45: error: syntax error before "jsize"
------------------

when i try to use jni.h in linux directory then the installation
is OK but when running the serial programe appear same error as
i told you before.

where can i find jni.h for FreeBSD ???
thanks.

~madrus~






_______________________________________________
XXXX@XXXXX.COM mailing list
http://www.yqcomputer.com/
To unsubscribe, send any mail to " XXXX@XXXXX.COM "
 
 
 

How to install JDK 1.4 on FreeBSD 5.4

Post by jonc » Mon, 25 Jul 2005 20:32:20


[ Please don't top-post]


jni.h comes with the java/jdk14 . You have *NOT* given us enough
information about what you are doing. Have you installed java/jdk14?
What did you do? Please provide us with all the details of:

1. what you're trying to achieve.
2. what you did to achieve this.

Cheers.
--
Jonathan Chen < XXXX@XXXXX.COM >
----------------------------------------------------------------------
When you don't know what you are doing, do it neatly.
_______________________________________________
XXXX@XXXXX.COM mailing list
http://www.yqcomputer.com/
To unsubscribe, send any mail to " XXXX@XXXXX.COM "
 
 
 

How to install JDK 1.4 on FreeBSD 5.4

Post by past » Mon, 25 Jul 2005 22:50:48


I would guess that this error is coming from compiling libSerial.c with
insufficient arguments, i.e. with "-I/usr/local/jdk1.4.2/include" but
without "-I/usr/local/jdk1.4.2/include/freebsd".

Of course one cannot be sure without more detailed information.

Cheers,

Panagiotis
_______________________________________________
XXXX@XXXXX.COM mailing list
http://www.yqcomputer.com/
To unsubscribe, send any mail to " XXXX@XXXXX.COM "
 
 
 

How to install JDK 1.4 on FreeBSD 5.4

Post by madru » Tue, 26 Jul 2005 09:20:34

Thanks Jonathan,
You're right, i am wrong source, right now, i have been trying
install the right source as you told me before.
Thanks again.

~madrus~







_______________________________________________
XXXX@XXXXX.COM mailing list
http://www.yqcomputer.com/
To unsubscribe, send any mail to " XXXX@XXXXX.COM "
 
 
 

How to install JDK 1.4 on FreeBSD 5.4

Post by madru » Tue, 26 Jul 2005 18:57:02

Thanks all,
It's work now.

~madrus~





_______________________________________________
XXXX@XXXXX.COM mailing list
http://www.yqcomputer.com/
To unsubscribe, send any mail to " XXXX@XXXXX.COM "