ISA Firewall error (Service not starts)

ISA Firewall error (Service not starts)

Post by QWhtZW » Sat, 13 May 2006 12:44:03


When ever my system restarts i get the following error:

Event ID - 21192
"The Microsoft Firewall was unable to connect to MSDE database. The MSDE
Error description is: Could not find database ID 283. Database may not be
activated yet or may be in transition., Multiple-step OLE DB operation
generated errors. Check each OLE DB status value, if available. No work was
done., Property value is invalid. Make sure the value is typed correctly.."


Firewall service startup type is Automatic but its not started and i have to
start it manually.

I am using Win 2003 and ISA 2004.

Any help would be highly appreciated.
 
 
 

ISA Firewall error (Service not starts)

Post by M » Sat, 13 May 2006 21:40:54

Hello,

This can be due to a timeout connecting to the MSDE database.
By default, the time out is set to 15 seconds. On large databases, of if
the ISA
server has multiple purposes (Exchange, DC, SQL) this can become a problem
as
resources are not always available within the default timeout period.

This timeout can be edited via the follwing registry value:

HKEY_LOCAL_MACHINE\Software\Microsoft\FPC\Reports
DatabaseQueryTimeout - RegDword

Setting this value to 300 decimal will provide a large enough timeout window
to
avoid this problem.

regards,

Henk

 
 
 

ISA Firewall error (Service not starts)

Post by QWhtZW » Tue, 16 May 2006 16:36:01

Hi,
Thanks for your reply, but im still getting the same error... in addition to
that error there is another entry at event log:

Failed to stop the fwsrv during Execution of alert actions. Use the source
location 118.316.4.0.2165.594 to report the failure. The computer should be
restarted.

When i restart the system or manually start the service, it works fine..?

Any suggestions would be highly appreciated
 
 
 

ISA Firewall error (Service not starts)

Post by SmFjayBEb3 » Sun, 27 Aug 2006 00:30:01

Hello,

I am also receiving the same exact errors. I am going to try out the
registry settings, however what of of the firewall service not starting upon
startup? This is still an issue for me, as well.

Thanks much, Jack Dorsey
 
 
 

ISA Firewall error (Service not starts)

Post by QWhtZW » Mon, 28 Aug 2006 19:11:01

Hi,
This may be due to the firewall, i have one domain controller and one
firewall machine. I got this error when my DC is down.

Thanks
 
 
 

ISA Firewall error (Service not starts)

Post by SmFjayBEb3 » Mon, 28 Aug 2006 21:17:01

don't think that's the problem in my case, but thanks for the advice. My
ISA server isn't on the same domain as my DC, and is in use as a perimeter
device.

"Ahmed" wrote: