c&c generals - zero hour - help plz

c&c generals - zero hour - help plz

Post by m3tho » Sun, 18 Jan 2009 19:54:44



hi, i have reasontly just bort a new pc, and fancyed putting some old
times classics on it like zero hour, however i have installed the game
fine and can play and get online fine however i can;t connect to people
very well, some times i get the odd connection here and there, but
general it goes, connecing players > awaiting probe responce >
connection failed :( the only othwer think i noticed as well the
start page where the menu is nothinking is moving or no sound (normaly u
have that lil battle between usa and gla in the back ground)

i am running the visa 64 bit on my new pc , and all my other c&c games
run perfectly on the max setting (ra3 / tibern wars e.t.c) i have a bt
home hub with the fire wall turned off, and i just use the windows
firewall & a anti virus and fire wall called eset smart. but i never had
a problem with any other games with it and its all allowed through. i
have tryed installing it and re installing and checked my settign to
make sure there not blocking it.

plz help :(


--
m3thod
 
 
 

c&c generals - zero hour - help plz

Post by Repeat6 » Sat, 24 Jan 2009 04:24:51


I'm running Zero Hour without a problem on Vista Ultimate x64 over here.
I did have some problems with multiplayer where my Windows Firewall
would block connections and hang the game for all players involved
(oops, sorry). After I got the firewall sorted, it works like a charm. I
did notice the into screen not showing an ongoing battle but a still
instead, as well. Haven't found a way around that though....


--
Repeat64
------------------------------------------------------------------------
Repeat64's Profile: http://www.yqcomputer.com/
View this thread: http://www.yqcomputer.com/

http://www.yqcomputer.com/

 
 
 

c&c generals - zero hour - help plz

Post by Richard » Tue, 27 Jan 2009 08:24:41


I also have the same issue. I'm Beta Testing Windows 7 64-Bit with this
game and I get the same result you guys are getting; a dead screen in
the background instead of the Battle that normally goes on in the
background. Of coarse that also means that there is no battle sounds
either. I am taking it upon myself to figure this out and I will post
the solution at that time. The game plays great though so it really is
no big deal.

Regards,

Rich


--
RichardV
 
 
 

c&c generals - zero hour - help plz

Post by Richard » Tue, 27 Jan 2009 09:29:04


Ok guys, I got it to work. So, here is everything I did.

1. Go to your "C:\Users\{your name}\Documents\Command and Conquer
Generals Zero Hour Data" folder and open options.ini. I set the
following settings:

AntiAliasing = 0
DrawScrollAnchor =
FirewallBehavior = 0
GameSpyIPAddress = 192.168.0.1 (make sure you use your own IP)
Gamma = 50
IPAddress = 192.168.0.1 (make sure you use your own IP)
IdealStaticGameLOD = High
LanguageFilter = false
MoveScrollAnchor = 0
MusicVolume = 61
Resolution = 800 600
Retaliation = yes
SFX3DVolume = 58
SFXVolume = 53
ScrollFactor = 60
SendDelay = no
StaticGameLOD = lOW
UseAlternateMouse = no
UseDoubleClickAttackMove = no
VoiceVolume = 70

This may or may not matter but do it anyway just to be sure.

2. right click on the .exe file that launches the game (or the shortcut
on your desktop), select "Properties", and set the following:

-under the "Shortcut" tab set Run: Maximized
-under the compatibility tab set Compatibility mode for "windows XP
service pack 2" but make sure you click it and make the check mark in
the box black, not grey.
-then, after you do the step above, click "Run this program as
administrator" and then click "Set these settings for all users" and
then apply everything, ok, etc.

The game should run now and the movie and sounds will play. Please let
me know if you have trouble.

Regards,

Rich


--
RichardV
 
 
 

c&c generals - zero hour - help plz

Post by Repeat6 » Wed, 28 Jan 2009 00:57:51


Your suggestion worked like a charm. I didn't touch the .ini file
though.


--
Repeat64
------------------------------------------------------------------------
Repeat64's Profile: http://www.yqcomputer.com/
View this thread: http://www.yqcomputer.com/

http://www.yqcomputer.com/
 
 
 

c&c generals - zero hour - help plz

Post by Richard » Wed, 28 Jan 2009 12:15:52


Cool!!! Glad to hear it Repeat64. So, anyone looking for the solution
just needs to do step 2 and all is well.

Regards,

Richard


--
RichardV