CodeWarrior 9.3 MachO Build Problems

CodeWarrior 9.3 MachO Build Problems

Post by David Burg » Thu, 23 Jun 2005 00:23:18


Hi,

I downloaded the CS2 SDK and found that there is a Mach-O CodeWarrior Sample
Importer, so I tried to compile it and got the following errors(Plus a lot
more that were caused by the error (not finding ansi.h)). I am using
CodeWarrior 9.3 as recommended in the documentation.

When I tried to build the Mach-O MSL Libraries I got the same errors, so I am
guessing that this is a CodeWarrior problem rather than an Adobe SDK Project
problem.

Do you have any idea what this could be?
Thanks a lot
Dave

Error : the file 'ppc/ansi.h' cannot be opened
(included from:
size_t.h:16
cstring_mach.h:12
cstring:20
string.h:17
ExceptionPPC.cp:101)
size_t_mach.h line 11 #includ<

Error : implicit 'int' is no longer supported in C++
(included from:
size_t.h:16
cstring_mach.h:12
cstring:20
string.h:17
ExceptionPPC.cp:101)
size_t_mach.h lin
 
 
 

CodeWarrior 9.3 MachO Build Problems

Post by David Burg » Thu, 23 Jun 2005 01:26:50

Hi Ron,

This happens when I try and compile the Mach-O Libraries, I am building
project: MSL_All_Mach-O.mcp, what should the access paths be for this
project?

Also should the "Interpret foreign path separators" box be checked or
un-checked?

Thanks a lot, All the Best
Dave


On Tue, 21 Jun 2005 16:41:50 +0100, MW Ron wrote
(in article < XXXX@XXXXX.COM >):


>> Importer, so I tried to compile it and got the following errors(Plus a >>> lot >>> more that were caused by the error (not finding ansi.h)). I am using >>> CodeWarrior 9.3 as recommended in the documentation. >>> >>> When I tried to build the Mach-O MSL Libraries I got the same errors, so I >>> am >>> guessing that this is a CodeWarrior problem rather than an Adobe SDK >>> Project >>> problem. >>> >>> Do you have any idea what this could be?gt;>>> >>>> Thanks a lot>>>> Dave>>>> >>>> Error : the file 'ppc/ansi.h' cannot be opened>>>> (included from:>>>> size_t.h:16>>>> cstring_mach.h:12>>>> cstring:20>>>> string.h:17>>>> ExceptionPPC.cp:101)>>>> size_t_mach.h line 11 #includ< >>>> >>>> Error : implicit 'int' is no longer supported in C++>>>> (included from:>>>> size_t.h:16>>>> cstring_mach.h:12>>>> cstring:20>>>> string.h:17>>>> ExceptionPPC.cp:101)>>>> size_t_mach.h lin>>>> > > > >