Getting Analog Design Environment to reread model files

Getting Analog Design Environment to reread model files

Post by Randy Yate » Sat, 22 Nov 2008 12:52:01


Hi,

I have some of my own model libraries setup and I often want to tweak
the parameters when performing simulations. However, from what I can
tell, it appears that the only way to get Cadence to reread the
files is to completely exit (I'm invoking "virtuoso" from the command
line) and then restart everything (library manager, schematic editor,
ADE). What a pain.

Does anyone know of a method to get Cadence/ADE to reread the model
files without leaving the environment?
--
% Randy Yates % "And all that I can do
%% Fuquay-Varina, NC % is say I'm sorry,
%%% 919-577-9882 % that's the way it goes..."
%%%% < XXXX@XXXXX.COM > % Getting To The Point', *Balance of Power*, ELO
http://www.yqcomputer.com/
 
 
 

Getting Analog Design Environment to reread model files

Post by gaitukevic » Sat, 22 Nov 2008 19:35:36

I had the same problem.
You just need to go to ADE->Setup->Model Libraries and perform Disable-
Enable for model file.

Regards

 
 
 

Getting Analog Design Environment to reread model files

Post by Randy Yate » Fri, 28 Nov 2008 01:42:48


XXXX@XXXXX.COM writes:


Thanks! That works great! (Sorry for the delay in responding.)
--
% Randy Yates % "She tells me that she likes me very much,
%% Fuquay-Varina, NC % but when I try to touch, she makes it
%%% 919-577-9882 % all too clear."
%%%% < XXXX@XXXXX.COM > % 'Yours Truly, 2095', *Time*, ELO
http://www.yqcomputer.com/
 
 
 

Getting Analog Design Environment to reread model files

Post by Andrew Bec » Sun, 21 Dec 2008 17:05:37

Randy Yates wrote, on 11/26/08 16:42:

Also, if you edit the files from the model library form (by hitting the edit
button), I think (if my memory is correct) that it automatically marks the
included file as "dirty" and so forces spectre to re-start.

The other approach is to use:

envSetVal("spectre.envOpts" "controlMode" 'string "batch")

before starting ADE. This means that spectre re-starts for every run, rather
than staying running. The downside is that parametric sweeps and quick
parameter-only changes are slower (the normal "interactive" mode means that it
doesn't need to restart, doesn't need to re-grab the license, and doesn't need
to re-read the netlist/models, and just change the parameter in memory), but
during a model development phase, it might be more convenient?

Regards,

Andrew.