Wedit.exe uses dll-function rated "XP or higher OS"

Wedit.exe uses dll-function rated "XP or higher OS"

Post by bjth » Sun, 14 Jun 2009 00:56:04


This bug description was added to the QSS-Bug pages yesterday...:

lcc-win32 download: 2009-05-17, OS: W2K SP4

Trying to open Wedit.exe, an error occurs like "procedure
SHGetFolderPathAndSubDirW not found in shell32.dll". Win SDK (XP SP2)
says about SHGetFolderPathAndSubDir (a ~W procedure isn't mentioned
explicitly) within the Function information:

Minimum DLL Version shell32.dll version 5.60 or later
Custom Implementation No
Header shlobj.h
Import library shell32.lib
Minimum operating systems Windows XP
Unicode Implemented as ANSI and Unicode versions.


Thus - that function isn't available within W2K (shell32.dll with
versions as 5.0.xxx).
Was there a new announcement not to support W2K anymore?

---------------------

Have to add, that the problem with that function exists also with the
wedit.exe from download 2009-05-10, because the wedit.exe of both
compilations is identical. Don't know, if some earlier download versions
are affected too.
Further I can't exclude a problem with the W2K-system I use here at the
moment, because I can't remember that problem from other machines with
W2K withn the last month - but possibly didn't work with Lcc-Win32 on W2K...

-----------------------

Verified with another W2K system - the lcc-win32 there was of March
2009, so I couldn't get the error.
Shell32.dll has also version 5.0.x


regards

bjthr
 
 
 

Wedit.exe uses dll-function rated "XP or higher OS"

Post by bjth » Wed, 01 Jul 2009 16:49:31

Same bug still with download 2009-06-28 - some more information on QSS
bug pages.

regards bjthr

 
 
 

Wedit.exe uses dll-function rated "XP or higher OS"

Post by bjth » Thu, 17 Sep 2009 03:36:09

Same bug still with download 2009-08-24 - some more information on QSS
bug pages.

regards bjthr
 
 
 

Wedit.exe uses dll-function rated "XP or higher OS"

Post by Friedrich » Fri, 18 Sep 2009 19:25:45

bjthr < XXXX@XXXXX.COM > writes:

I've send Jacob a rewrite and hopefully this problem is solved with
that...

Regards
Friedrich

--
Please remove just-for-news- to reply via e-mail.
 
 
 

Wedit.exe uses dll-function rated "XP or higher OS"

Post by jacob navi » Fri, 18 Sep 2009 20:07:37

Friedrich Dominicus a rit :

Yes, I uploaded that patch yesterday
 
 
 

Wedit.exe uses dll-function rated "XP or higher OS"

Post by bjth » Mon, 21 Sep 2009 04:58:01


Last download from QSS works!

Thanks a lot!

bjthr