DOS base btrieve application error in Windows XP DOS box

DOS base btrieve application error in Windows XP DOS box

Post by hama » Sat, 21 Feb 2004 15:12:23


Hi,

We have a client running a legacy DOS based ERP system.
We are trying to run the DOS application in the DOS box under
Windows XP with Netware client 4.83 sp2e.
The application can access the database in a Netware 3.11 server
running brieve. But we got errors from some of the functions.
The application can run in DOS box on Windows 98 with Netware
client 3.4 for windows without any problem.

After running "brequest.exe /d:8192" and then "brequtil.exe -ver",
we got

BREQUTIL - Btrieve Requester Utility Version 6.10b
Copyright 1993 Novell Inc. All Rights Reserved.

BREQUTIL-6.1-4: The Btrieve version is 6.10 for NetWare.

I have search the google and have found no solution for this.
Is there anyway to solve the problem?

Regards,

hama
 
 
 

DOS base btrieve application error in Windows XP DOS box

Post by Brad Kunke » Sun, 22 Feb 2004 02:36:57


What errors do you get?

--
Brad Kunkel
Integrated Business, Inc.

 
 
 

DOS base btrieve application error in Windows XP DOS box

Post by hama » Tue, 24 Feb 2004 10:51:09


The ERP is Paradigm 1.15 from Cimnet System. The database is btrieve 6.10.

The error we got is:
MODULE: A0204 QBASIC-ERR 76

The client has stopped the support long ago, so no support from the vendor anymore.
We've tried the brequest.exe from the original dos client they use, and also the
brequest.exe in c:\pvsw\clients\dos in Pervasive SQL 7. They both produce the same
error code in some modules (but not all).

Should I just give up trying to run the client on Windows 2000/XP/2003?

Regards,

Hama
 
 
 

DOS base btrieve application error in Windows XP DOS box

Post by Bill Bac » Tue, 24 Feb 2004 20:53:45

You're problem is with the QuickBASIC side, not with the database. QB Error 76
translates to "Path Not Found". If your client purchased the Folio Knowledgebase like
they were supposed to, then they should be able to find possible solutions to the QB76
in the HelpLine database, which should be located in \CSI\DOCUMENT or something like
that.

The Customer Maintenance Module (damn, I hate my memory sometimes) may or may not
require the use of any temporary files. First, make sure that the user being logged in
has valid access to the \CSI directory structure, and that folders like \CSI\TEMP and
\CSI\NULL exist.

Worst case, try downloading a set of tools from http://www.yqcomputer.com/ , especially
FileMon. Run this to monitor all file system access on the computer, and it should
tell you what directory path the application is trying to access.
 
 
 

DOS base btrieve application error in Windows XP DOS box

Post by hama » Wed, 25 Feb 2004 17:36:54

Hi Bill,

The program works after I created the \CSI\NULL directory.
The QBASIC ERR 76 is gone.

Thanks.
I tried to run filemon on the windows XP client but found nothing.

Regards,

hama
 
 
 

DOS base btrieve application error in Windows XP DOS box

Post by hama » Wed, 25 Feb 2004 17:44:47

Bill,

It's strange. Windows 98 clients function normally without the /CSI/NULL directory.

Thanks.

hama
 
 
 

DOS base btrieve application error in Windows XP DOS box

Post by Bill Bac » Wed, 25 Feb 2004 19:57:18


Definitely strange, I agree. The \CSI\NULL directory is required, and was always needed
for DOS computers, way back when.

BTW, what is the site name? I actually just heard from another site in Canada running
V1.16 still and looking for database licenses...