Oracle RAC 9.2 starting problem with srvctl and some ORA-7445

Oracle RAC 9.2 starting problem with srvctl and some ORA-7445

Post by skyste » Thu, 07 Jan 2010 00:09:21


Hello,

today an old oracle rac 9.2 database crashed to due power problem. Both
nodes were restarted.

Manually I've restard oracm as root and the gsdctl as oracle user.

Now running

srvctl start instance -i INST1 -d INST

works, as the instance was started, but srvctl command remains waiting
on my console. Tracing was previously enabled and command is waiting on

[..snip..]
[main] [16:3:1:459] [ParallelServer.startInstance:1362] instEnviron:
finalEnv[0]=ORACLE_HOME=/orasw/app/oracle/product/9.2.0
[main] [16:3:1:461] [ParallelServer.startInstance:1362] instEnviron:
finalEnv[1]=ORACLE_SID=INST1
[main] [16:3:1:474] [NativeSystem.<init>:123] Detected Cluster
[main] [16:3:1:478] [NativeSystem.<init>:124] Cluster existence = true
[main] [16:3:1:481] [UnixSystem.<init>:118] loaded libraries
[main] [16:3:1:491] [NativeSystem.<init>:123] Detected Cluster
[main] [16:3:1:494] [NativeSystem.<init>:124] Cluster existence = true
[main] [16:3:1:497] [UnixSystem.<init>:118] loaded libraries
[main] [16:3:1:500] [RemoteCommand.<init>:117] Returning an existing
instance of GetActiveNodes
[main] [16:3:1:503] [StartAction.executeInstance:200] submitting
startinstance command
[main] [16:3:1:508] [ClusterCmd.submit:95] Returning same instance to
clientmain
[main] [16:3:1:510] [ClusterCmd.submit:97] Entering submit
[main] [16:3:1:513] [SyncBuffer.put:36] empty:Acquire called by thread
main count=2
[main] [16:3:1:516] [SyncBuffer.put:38] full:Release called by thread
main count=1
[Worker 0] [16:3:1:519] [SyncBuffer.get:46] empty:Release called by
thread Worker 0 count=2
[main] [16:3:1:518] [SyncBuffer.get:46] block called by thread main
commandNum 1
[Worker 0] [16:3:1:521] [line# N/A] RemoteCommand.execute: s_opsmDaemon
is not null false
[main] [16:3:1:521] [ClusterConfig.block:413] ClientResource
Constructor:Blocking Semaphore owned by main:Acquire called by thread
main count=0


I'm not able to understand this. Metalink seems not helping me.
Also many queries generate an ORA-7445 as:

Errors in file /orasw/app/oracle/admin/INST/udump/cinf351a_ora_28544.trc:
ORA-07445: exception encountered: core dump [__libc_free+192] [SIGSEGV]
[unknown code] [0x5F6765725F73655F] [] []
Tue Jan 5 16:05:03 2010
Errors in file /orasw/app/oracle/admin/INST/udump/cinf351a_ora_28544.trc:
ORA-07445: exception encountered: core dump [Unw_get_reg+320] [SIGSEGV]
[unknown code] [0x0005356B3] [] []
ORA-07445: exception encountered: core dump [__libc_free+192] [SIGSEGV]
[unknown code] [0x5F6765725F73655F] [] []
Tue Jan 5 16:05:04 2010
Errors in file /orasw/app/oracle/admin/INST/udump/cinf351a_ora_28544.trc:
ORA-07445: exception encountered: core dump [Unw_get_reg+320] [SIGSEGV]
[unknown code] [0x0005356B3] [] []
ORA-07445: exception encountered: core dump [Unw_get_reg+320] [SIGSEGV]
[unknown code] [0x0005356B3] [] []
ORA-07445: exception encountered: core dump [__libc_free+192] [SIGSEGV]
[unknown code] [0x5F6765725F73655F] [] []


Both functions are not published.

Any hints?


Thanks
Stefano