Cisco 827 VPN over bridged DSL

Cisco 827 VPN over bridged DSL

Post by nmoronit » Thu, 07 Oct 2004 01:08:44


I have a static IP address on a ADSL line from Verizon at location A.
I had to configure my Cisco 827 router for bridging on the ATM
interface and configure the IP address on the BVI Interface. It is
working fine. Now I want to create an ipsec tunnel with another 827
at location B. The tunnel is established but encrypted network is not
routing. I nother words, I have created a tunnel so that private
network 192.168.1.x at location A can route to 192.168.2.x at location
B, but I can only ping the Ethernet interface on router A from the B
network for some reason. All other nodes time out.

Here is my config:

Current configuration : 1855 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname XX
!
logging rate-limit console 10 except errors
enable password 7 xxxxxxxxxxx
!
ip subnet-zero
no ip finger
!
no ip dhcp-client network-discovery
!
!
crypto isakmp policy 20
authentication pre-share
group 2
crypto isakmp key xxxxxxxxxxxx address xxx.xxx.xxx.195
!
!
crypto ipsec transform-set dsl esp-des esp-md5-hmac
!
crypto map tunnelct 10 ipsec-isakmp
set peer xxx.xxx.xxx.195
set transform-set dsl
match address 110
!
bridge irb
!
!
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
no ip mroute-cache
no atm ilmi-keepalive
pvc 0/35
encapsulation aal5snap
!
bundle-enable
dsl operating-mode auto
bridge-group 1
hold-queue 224 in
!
interface BVI1
ip address xxx.xxx.xxx.26 255.255.255.0
ip nat outside
crypto map tunnelct
!
ip classless
ip route 0.0.0.0 0.0.0.0 BVI1
no ip http server
!
ip nat inside source route-map nonat interface BVI1 overload
access-list 101 deny ip 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
access-list 110 permit ip 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255
route-map nonat permit 10
match ip address 101
!
bridge 1 protocol ieee
bridge 1 route ip
banner motd ^C Access is Prohibited. Violators will be Prosecuted! ^C
!
line con 0
password 7 xxxxxxxxxxxx
login
transport input none
stopbits 1
line vty 0 4
exec-timeout 0 0
password 7 xxxxxxxxxx
login
!
scheduler max-task-time 5000
end
 
 
 

1. Windows 2K/XP -> Cisco 827 VPN?

2. Howto: Windows client - cisco 827 VPN? Possible?

Hi,

What I'd like to accomplish is to be able to see the inside of a NAT
created by the 827 from remote windows 2k/XP workstations.

In order of preference, I'd like to use:
1) The native VPN client on 2k/XP
2) Some 3rd party application that does not require SW installation
(Is this even possible? I'd really like to avoid having to
install software just to access my inside network to get
a file or whatever)
3) VPN client that requires software installation

For some reason, this seems terribly complicated if at all possible.
(?)

Right now, I'm using SSH (via tcp port 22 forwarded to a linux box) to
forward selected ports when I need them. What I really want is for the
host to get an IP address from the inside of the 827's NAT in addition
to the one it already has.

Isn't this a very-FAQ? I have found no solutions to this. Especially
no easy ones.... I tried with a post detailing my failed attempt,
http://www.yqcomputer.com/ %40posting.google.com
but since that didn't get any replies I'm rephrasing it:

What are my options? IPSec? VPN/SSL?? (PPTP?) How is this done?
Or: Why is this a brain-dead idea?

Sincerely + Happy New Year!

Peter

3. Cisco 877 & Cisco 827 as backup

4. URGENT: need help in QOS for cisco 827 and cisco 1600

5. 827 DSL Router

6. Would like to get my Cisco 827 not to reply to PING requests

7. Cisco 827 ADSL Router

8. Cisco 827, flash memory and IOS...

9. Cisco 827 ADSL Configuration Help

10. Problem with a Cisco 827 Router

11. Cisco 827 and ssh access

12. I have a problem with Cisco 827.

13. Cisco 827 g.dmt commands

14. Cisco 827 beginners fun...

15. Cisco 827 -> SMTP nat problem!