DHCP over IPSEC through a d-li 504T DSL box

DHCP over IPSEC through a d-li 504T DSL box

Post by A.Shara » Fri, 09 Jul 2004 20:36:40


Hi all,

Got a small problem here.

I'm trying to set up a VPN link from my pc at home to a VPN gateway
I've got at work.

The client pc is connected to a local network via a d-link 504T dsl
beast which also has a 4 port 10/100 hub.

The VPN client is from the same company that I purchased the VPN
gateway from.

If I tell the client not to request a dynamic IP address (dhcp over
IPSEC) everything works and I get connected to our Univ network.

If I tel the client to enable dhcp over ipsec then I get as far as (I
think) waiting for an ip address to be handed back to the client. I
can see the dhcp server at the other end handing out an apropriate
address, it just doesn't get as far as the PC.

Someone else with a broadband connection who has their machine
directly connected to their broadaband connection picks up the IP
address just fine.

I'm wondering if there is something on the D-Link 504T that's stopping
the dhcp request from being passed back to the PC

Any thoughts?

Alex
 
 
 

DHCP over IPSEC through a d-li 504T DSL box

Post by T. Sean We » Sat, 10 Jul 2004 05:57:10


Since there are so many variables invloved that could be causing this,
more info is needed, starting with what vendor is the VPN box and client?

--
T. Sean Weintz - T. Sean Weintz - T. Sean Weintz - T. Sean Weintz
May be copied freely without the express permission of T. Sean Weintz.
T. Sean Weintz could care less. T. Sean Weintz does reserve all rights.
T. Sean Weintz - T. Sean Weintz - T. Sean Weintz - T. Sean Weintz