Unexpected row shift using SAP BW OleDb provider with SAP BW 3.5

Unexpected row shift using SAP BW OleDb provider with SAP BW 3.5

Post by Julien Ch » Fri, 20 May 2005 18:23:03


Hi all,

I have created a Microsoft .NET windows application (in C#) which reads
and displays data directly from SAP BW using

the SAP BW OleDb provider. The application simply connects to the SAP
BW system and executes against it a very

simple MDX query :

SELECT
[0CALMONTH2].[LEVEL01].Members ON COLUMNS,
[ZCOUNTRY].[LEVEL01].Members ON ROWS
FROM [$ZMYCUBE]
WHERE [Measures].[ZSALES]

The application returns expected results when the MDX query is executed
against a SAP BW 3.1. But, if the MDX query

is executed against a SAP BW 3.5 containing the very same cube, there
is a row shift on the dimension column (the

first column). Here is the detailed illustration of this unexpected
behavior:

Here is the expected results, which is correctly obtained in my .NET
application using the SAP BW OleDb provider

connecting to a SAP BW 3.1 system :

Jan Fev Mar
----------------------------
DE 60 80 85
FR 120 100 120
UK 140 110 110

And here is the obtained results in my .NET application using the same
SAP BW OleDb provider, connecting to a SAP BW

3.5 system :

Jan Fev Mar
----------------------------
FR 60 80 85
UK 120 100 120
140 110 110

The "DE" country has disappeared and other countries have been shifted
1 row up ! But note that measures values for

columns "Jan", "Fev" and "Mar", didn't move.

- I made this test using many different versions of the SAP BW OleDb
provider for Olap, and I encountered the same

problem with all of them.
- Plus that, I tested the MDX query using the MDXTEST tool on both 3.1
and 3.5 versions of SAP BW and both systems

returned correct and expected results.
- I also could reproduce the bug on different SAP BW 3.5 systems.

I think SAP BW 3.5 doesn't return the same structure of data results,
thus making the SAP BW OleDb provider

interpreting incorrectly. Did anyone had this problem and is there a
patch which could fix it? Thanks in advance.

Best regards,

Julien
 
 
 

1. Unexpected row shift using SAP BW OleDb provider with SAP BW 3.5

2. Connecting MS SQL to SAP BW using SAP BW OLE DB Provider

I am trying to connect to a SAP BW database from MS SQL2K through a
DTS Package using the standard SAP BW OLE DB Provider connection.

The connection test is OK but after selecting the catalogue and moving
through to selecting the Tables to import I can see only tables that
are both not recognised and as far as I can see do-not exist but none
of the objects that have been created.

We have tried different user ID, authorisation etc but with no luck.

Has anyone seen this type of problem before ?

Thx

N

--
http://www.yqcomputer.com/ 's request
Articles individually checked for conformance to usenet standards
Topic URL: http://www.yqcomputer.com/
Visit Topic URL to contact author (reg. req'd). Report abuse: http://www.yqcomputer.com/

3. sap IDES of BI 7.0\\ SAP 4.7\\ ECC 5.0\\ ECC 6.0\\CRM \\ BW 3.5

4. US-NJ-Newark: SAP SEM/BW Programmer, SAP Basis SEM/BW; 5M (45299060413)

5. US-NJ-Newark: SAP SEM/BW Programmer, SAP Basis SEM/BW; 5M (45299060412)

6. US-AL-Huntsville: SAP Functional Support, SAP R/3 FI/CO, SAP BW; C-P (45300757603)

7. US-AL-Huntsville: SAP Functional Support, SAP R/3 FI/CO, SAP BW; C-P (45300157603)

8. US-AL-Huntsville: SAP Functional Support, SAP R/3 FI/CO, SAP BW; C-P (45301932406)

9. US-AL-Huntsville: SAP Functional Support, SAP R/3 FI/CO, SAP BW; C-P (45300132410)

10. US-AL-Huntsville: SAP Functional Support, SAP R/3 FI/CO, SAP BW; C-P (45298957602)

11. US-AL-Huntsville: SAP Functional Support, SAP R/3 FI/CO, SAP BW; C-P (45299557601)

12. US-AL-Huntsville: SAP Functional Support, SAP R/3 FI/CO, SAP BW; C-P (45298937160)

13. US-AL-Huntsville: SAP Functional Support, SAP R/3 FI/CO, SAP BW; C-P (45299232412)