SSAS with an Instance name

SSAS with an Instance name

Post by Sm9yZ2 » Wed, 21 Jun 2006 02:56:01


Hi, we are using a SSAS with a named instance (SQL2K5) and just configured
XMLA 1.1, but it brings an error: Datasource Local Analysis Server not found

where "Local Analysis Server" is the DataSourceName and my
<DataSourceInfo>Provider=MSOLAP.2;Data Source=mypc\sqk2k5</DataSourceInfo>

Is there a problem with the named instance?

Thanks,
 
 
 

SSAS with an Instance name

Post by Akshai Mir » Wed, 21 Jun 2006 07:21:34

The XMLA SDK 1.1 is only supported against AS 2000.

AS 2005 natively supports XMLA. For AS 2005 you should just configure HTTP
access to the server using instructions here:
http://www.yqcomputer.com/

Thanks,
Akshai

--
This posting is provided "AS IS" with no warranties, and confers no rights
Please do not send email directly to this alias. This alias is for newsgroup
purposes only.

 
 
 

SSAS with an Instance name

Post by Sm9yZ2 » Wed, 21 Jun 2006 08:22:01


I have configured HTTP to access the SSAS server and it is working fine with
the default instance, but I need to query a named instances (local\sql2k5),
so I change did the following:

1. instance name to SQL2K5
2. changed the msmdpump.ini, the ServerName to: wsdti\sql2k5

But we are getting this error:

The following system error occurred: No connection could be made because the
target machine actively refused it. .

Thanks,
Jorge
 
 
 

SSAS with an Instance name

Post by Akshai Mir » Wed, 21 Jun 2006 12:17:23

This should work. How are you trying to connect to it?

Apparently the ISAPI DLL (msmdpump.dll) is for some reason unable to open a
connection to the named instance. You should verify that OLE DB is able to
connect to the named instance (e.g. try to use Excel on that machine to
connect to that server).

It could also be a permissions problem somehow -- you can try to run
Profiler against the server and see if it shows an event indicating a
failure to logon...

HTH,
Akshai
This posting is provided "AS IS" with no warranties, and confers no rights
Please do not send email directly to this alias. This alias is for newsgroup
purposes only.
 
 
 

SSAS with an Instance name

Post by Sm9yZ2 » Thu, 22 Jun 2006 01:47:02

hanks Akshai for the help,,, but it not working on the development machine
(Windows XP, SSAS 2005 no Service Pack), these are the facts:

- We are able to connect to the named instance from Excel without passing
any userid or password (we have assigned permissions to everyone in the
development machine)
- When using the named instance (and configured properly the msmdpump.ini
file) the Profiler doesn detect any events (not even a SessionStart or
LogInFailure) and the web service returns the message: o connection could
be made because the target machine actively refused it. . (with two dots at
the ending)
- If we rename the instance to be the default instance (and configured
properly the msmdpump.ini file) the XMLA is returned and the Profiler detects
all the events.


"Akshai Mirchandani [MS]" wrote:
>> This should work. How are you trying to connect to it? >> >> Apparently the ISAPI DLL (msmdpump.dll) is for some reason unable to open a >> connection to the named instance. You should verify that OLE DB is able to >> connect to the named instance (e.g. try to use Excel on that machine to >> connect to that server). >> >> It could also be a permissions problem somehow -- you can try to run >> Profiler against the server and see if it shows an event indicating a >> failure to logon... >> >> HTH, >> Akshai >> -- >> Try out the MSDN Forums for Analysis Services at: >> http://forums.microsoft.com/MSDN/ShowForum.aspx?ForumID=83&SiteID=1 >> >> This posting is provided "AS IS" with no warranties, and confers no rights >> Please do not send email directly to this alias. This alias is for newsgroup >> purposes only. >> >> "Jorge"<< XXXX@XXXXX.COM >> wrote in message >> news: XXXX@XXXXX.COM ... >>>> >>>> I have configured HTTP to access the SSAS server and it is working fine >>>> with >>>> the default instance, but I need to query a named instances >>>> (local\sql2k5), >>>> so I change did the following: >>>> >>>> 1. instance name to SQL2K5 >>>> 2. changed the msmdpump.ini, the ServerName to: wsdti\sql2k5 >>>> >>>> But we are getting this error: >>>> >>>> The following system error occurred: No connection could be made because >>>> the >>>> target machine actively refused it. . >>>> >>>> Thanks, >>>> Jorge >>>> >>>> "Akshai Mirchandani [MS]" wrote: >>>> >>>>> The XMLA SDK 1.1 is only supported against AS 2000. >>>>> >>>>> AS 2005 natively supports XMLA. For AS 2005 you should just configure >>>>> HTTP >>>>> access to the server using instructions here: >>>>> http://www.microsoft.com/technet/prodtechnol/sql/2005/httpasws.mspx >>>>> >>>>> Thanks, >>>>> Akshai >>>>> >>>>> -- >>>>> -- >>>>> Try out the MSDN Forums for Analysis Services at: >>>>> http://forums.microsoft.com/MSDN/ShowForum.aspx?ForumID=83&SiteID=1 >>>>> >>>>> This posting is provided "AS IS" with no warranties, and confers no >>>>> rights >>>>> Please do not send email directly to this alias. This alias is for >>>>> newsgroup >>>>> purposes only. >>>>> >>>>> "Jorge"<< XXXX@XXXXX.COM >> wrote in message >>>>> news: XXXX@XXXXX.COM ... >
 
 
 

SSAS with an Instance name

Post by Akshai Mir » Fri, 23 Jun 2006 03:54:32

he error appears to indicate that the service isn't running on the expected
port... My guess would be that for some reason your msmdpump.ini isn't being
loaded at all and it is using the default values.

Unfortunately this type of issue isn't very easy to solve remotely... You
could try to use FileMon to see if the ISAPI DLL tries to load msmdpump.ini
(and from the correct location).

I would also highly recommend moving the server to SP1 -- there were several
issues fixed related to HTTP and Pump connectivity (although nothing that
sounds like your scenario).

Thanks,
Akshai
This posting is provided "AS IS" with no warranties, and confers no rights
Please do not send email directly to this alias. This alias is for newsgroup
purposes only.

"Jorge" < XXXX@XXXXX.COM > wrote in message
news: XXXX@XXXXX.COM ...


 
 
 

SSAS with an Instance name

Post by TWlsZHJlZ » Tue, 14 Aug 2007 20:44:01

kshai..I am having a similar problem. I am using OWC to access a cube in sql
analysis 2005 database. The SQL 2005 server is a named instance. When I use
the named instance as the server name to access the cube from OWC, it works
fine. But I will need to display the cube over the internet which is why I
have configured http to access the SSAS server.
Now when I give the servername as http://servername/olap/msmdpump.dll and
try to access it , it throws me the error
"The following system error occurred: No connection could be made because
the target machine actively refused it. ."
The msmdpump.ini displays localhost as the servername. I tried changing it
to the named instance too but still no change.
Another thing i noticed is that the C:\Program Files\Microsoft SQL
Server\90\Shared\ASConfig\msmdredir.ini file displays the port as 1052 with
the servername as the 2005 server instance name.
Do I need to put this port number somewhere in the msmdpump ini?
Thanks
Mildred

"Akshai Mirchandani [MS]" wrote: