Dll failure

Dll failure

Post by saiprasa » Tue, 16 Sep 2003 08:05:47


Hi all,

I am getting ERROR_GEN_FAILURE when an application is accessing an exported
function in the DLL .Therefore i have to return TRUE when i see this
error.Can any one help me out with the reason for cause of the error.
As far as my knowledge is concerned i am not trying to import a function
that is not being exported which is the best cause of this error.
Please let me know what is the cause of that error and how i can avoid that.

thanks
sai
 
 
 

Dll failure

Post by Gary Chans » Tue, 16 Sep 2003 10:49:13


Have you examined the DLL with a tool like Depends to see if it is
really exporting the function with the name you expect? A common cause of
this type of problem is exporting the function using the decorated name.

--

-GJC
-Software Consultant (Embedded systems and Real Time Controls)
XXXX@XXXXX.COM

-Abolish public schools

 
 
 

Dll failure

Post by saiprasa » Wed, 17 Sep 2003 08:27:12

Hi Gary ,

Can u explain me what do u mean by decorative name.I used depend.exe to see
if i am missing anything.still the same problem i have to return TRUE when i
see that error.

thanks
sai




exported
that.
 
 
 

Dll failure

Post by Gary Chans » Wed, 17 Sep 2003 09:53:44


If you're seeing the proper function in Depends, then you don't have
that problem (which is related to the way the C++ compiler manages names).

I don't know what else to suggest. It might help if you post some
relevant code for us to look at.

--

-GJC
-Software Consultant (Embedded systems and Real Time Controls)
XXXX@XXXXX.COM

-Abolish public schools