Can't open database connections after building stand-alone application

Can't open database connections after building stand-alone application

Post by Thom » Sun, 04 Apr 2004 00:55:03


When using the database connectivity toolkit in LV 7.0 I can connect
to ODBC or OLE data sources and use them without a problem. Once the
stand-alone application is built I get the following error for ODBC.

DB Tools Open Connec (String).vi->test-db-app.vi<ERR>Exception occured
in Microsoft OLE DB Provider for ODBC Drivers, [MySQL][ODBC 3.51
Driver]Can't connect to MySQL server on 'neuromancer.uky.edu' (10061).
in DB Tools Open Connec (String).vi->test-db-app.vi

or for OLE:

DB Tools Open Connec (String).vi->DB Tools Open Connec
(Path).vi->test-db-app.vi<ERR>Exception occured in Provider,
Unspecified error. in DB Tools Open Connec (String).vi->DB Tools Open
Connec (Path).vi->test-db-app.vi

Anyone have any ideas?

Thom Coates
 
 
 

Can't open database connections after building stand-alone application

Post by Feroz » Wed, 07 Apr 2004 01:29:27

Hi Thom,
A quick way to narrow this problem down is to try connecting to an
Access or MS SQL database on your computer. This will remove MySQL
out of the picture and will allow us to make sure that the code in
LabVIEW is written correctly.

Please let me know how this goes.

Feroz

 
 
 

Can't open database connections after building stand-alone application

Post by Crysta » Wed, 07 Apr 2004 02:44:29

Thom,

I built an application from a VI that I use to communicate with mySQL
and it worked just fine. Did you make sure to define the connection
on the target computer (ie, use ODBC Administrator to define the DSN
or include the *.udl file with the project and verifying the
connection worked)

What OS is your target machine? If it's Win9x or NT, then MDAC isn't
included with the OS and you need to install it separately. Chapter 6
of the Database Connectivity Toolset User Manual describes how to do
this.