Looking for AIX 5.2 binaries, IS anyone running Ruby on AIX 5.2 ??

Looking for AIX 5.2 binaries, IS anyone running Ruby on AIX 5.2 ??

Post by bww00amdah » Sat, 09 Jul 2005 00:32:29


Looking for AIX 5.2 binaries, IS anyone running Ruby on AIX 5.2 ??


Regards
Bryan Webb
 
 
 

Looking for AIX 5.2 binaries, IS anyone running Ruby on AIX 5.2 ??

Post by Matt Lawre » Sat, 09 Jul 2005 00:38:05


We are still running 5.1 here at work and planning to go directly to 5.3
later on this year.

-- Matt
Nothing great was ever accomplished without _passion_

 
 
 

Looking for AIX 5.2 binaries, IS anyone running Ruby on AIX 5.2 ??

Post by Philippe L » Sat, 09 Jul 2005 01:27:30


We are running ruby 1.8.3 on AIX 5.2.

It's more easier to build ruby on AIX with the 1.8.3 version. But you will
have to work around the configuration options specially with GCC compiler.

Philippe Lucas.
 
 
 

Looking for AIX 5.2 binaries, IS anyone running Ruby on AIX 5.2 ??

Post by bww00amdah » Sat, 09 Jul 2005 01:36:33

Anyone have the GCC compiler options required ????



Thanks
Bryan
 
 
 

Looking for AIX 5.2 binaries, IS anyone running Ruby on AIX 5.2 ??

Post by Austin Mo » Sat, 09 Jul 2005 02:12:12

A while back I asked the guys at Bull Freeware
( http://www.yqcomputer.com/ ) if they could get Ruby 1.8.2 running on
AIX 5.2 because I never could. Well... I could but without the socket
library.

They have a Ruby 1.8.2 binary posted there that you can install via
SMIT. I'm running it now but it still has some problems. Most notably
for me is the missing zlib library so I haven't been able to use
rubygems.

I haven't had a chance to try 1.8.3... if someone could post any
options they had to use for GCC that would be great.
 
 
 

Looking for AIX 5.2 binaries, IS anyone running Ruby on AIX 5.2 ??

Post by Philippe L » Sat, 09 Jul 2005 20:54:09


GCC :
Reading specs from
/usr11/home/local/gcc-344/bin/../lib/gcc/powerpc-ibm-aix5.2.0.0/3.4.4/specs
Configured with:
./configure --prefix=/usr/local/gcc-344 --enable-threads=posix --enable-lan
guages=c,c++,f77,java --disable-nls
Thread model: aix
gcc version 3.4.4


RUBY 1.8.3 :
./configure
INSTALL="/usr/bin/installbsd -c" --prefix=/usr/local/ruby-183 --enable-insta
ll-doc --enable-shared --disable-ipv6


See the attached file rbconfig.rb for GCC and ld parameters.

See also messages sent a month ago to ruby-talk about Ruby 1.8.3 and AIX
5.2.

You have to do somes changes in configure.mk and configure.in.

You can also build it in static mode.

GCC parameters works for GCC > 2.9


Philippe Lucas