32-Bit TAPISRV with 64-Bit RemoteSP (and 32-Bit TapiClient) gets no incoming calls

32-Bit TAPISRV with 64-Bit RemoteSP (and 32-Bit TapiClient) gets no incoming calls

Post by philipp.re » Thu, 17 Jul 2008 23:24:22


Hello!
Here's my configuration:

TAPISRV: Windows 2003 Server SP2 (and Windows 2000 Server SP4), both
with AVAYA 3rd party TAPI
RemoteSP: Windows 2003 x64 R2 SP2 (and Windows 2003 x86 SP2)

My problem:
Ich can use the lines provided by the RemoteSP (on x64 Windows) to
dial out, but i can't see any incoming calls.
When I use a 32-Bit Windows 2003 with RemoteSP one the client side
everything works fine, but I need more than 4GB memory on the client
server.

Someone mentioned a problem like this before, but there was no
solution:

http://www.yqcomputer.com/ +incompatible+tcmsetup&qt_s=Search

Could anyone help?

Philipp
 
 
 

32-Bit TAPISRV with 64-Bit RemoteSP (and 32-Bit TapiClient) gets no incoming calls

Post by Matthias M » Fri, 18 Jul 2008 00:51:16

Philipp,

after reading the other post and taking into consideration that you
encounter the same issue it seems to me that this is probably an
impersonation or other bug in the RemoteSP on x64.
I think your best bet is to contact Microsoft support and try to
get a hotfix for this issue.
Though, don't expect them to have a PBX ready for reproduction
of this problem. You need to try to create a reproduction scenario
for them. Possible solutions would be to use the H.323 TSP (which
would require a third computer to create the call) or the ESP
(economical service provider), but I'm not sure if it works on
W2k3...


Best regards,

Matthias Moetje
-------------------------------------
TAPI WIKI: http://www.yqcomputer.com/
-------------------------------------
TERASENS GmbH
Augustenstra遝 24
80333 Munich, GERMANY
-------------------------------------
e-mail: moetje at terasens dot com
www: www.terasens.com
-------------------------------------

 
 
 

32-Bit TAPISRV with 64-Bit RemoteSP (and 32-Bit TapiClient) gets no incoming calls

Post by Andreas Ma » Fri, 18 Jul 2008 02:36:40

< XXXX@XXXXX.COM > schrieb im Newsbeitrag


http://www.yqcomputer.com/ +incompatible+tcmsetup&qt_s=Search

Philipp, in addition to Matthias reply,
You may want to enable OS internal TAPI tacing on the client for REMOTESP and
on the server for TAPISRV and see whether there are any errors reported in the
logs.
Please post the logs.
See my TAPI and TSPI FAQ:
Q: Is there a TAPI trace available ?
http://www.yqcomputer.com/ 's_TAPI_and_TSPI_FAQ.htm#_Q:_Is_there_10

--
Best Regards
Andreas Marschall
Microsoft MVP for TAPI / Windows SDK / Visual C++
TAPI / TSP Developer and Tester
My TAPI and TSPI FAQ:
http://www.yqcomputer.com/ 's_TAPI_and_TSPI_FAQ.htm
My Toto?Tools (a collection of free, mostly TAPI related tools):
http://www.yqcomputer.com/ 's_Toto_Tools.htm
TAPI development around the world (Frappr! map):
http://www.yqcomputer.com/
* Please post all messages and replies to the newsgroup so all may
* benefit from the discussion. Private mail is usually not replied to.
* This posting is provided "AS IS" with no warranties, and confers no rights.
 
 
 

32-Bit TAPISRV with 64-Bit RemoteSP (and 32-Bit TapiClient) gets no incoming calls

Post by philipp.re » Sat, 19 Jul 2008 09:33:51

I did the tracing, you'll find the results under:

http://www.yqcomputer.com/ ~reitberger/tapi-problem.zip

Hope you'll find someting :)
 
 
 

32-Bit TAPISRV with 64-Bit RemoteSP (and 32-Bit TapiClient) gets no incoming calls

Post by Andreas Ma » Wed, 30 Jul 2008 01:31:06

< XXXX@XXXXX.COM > schrieb im Newsbeitrag


Philipp,
the RemoteSP logs show repeatedly this:
[ERROR] RemoteDoFunc: RpcImpersonateClient failed, err=1725

So it seems to be an impersonation issue like Matthias already suggested.

I've seen these errors on other RemoteSP.TSP issues too, but haven't got a
solution.
Some contacts to MS support couldn't clarify these either.

I am currently testing with 64-bit OS (WS2k3, WS2k8) so maybe I can repro this
here and shed some more light on it.

--
Best Regards
Andreas Marschall
Microsoft MVP for TAPI / Windows SDK / Visual C++
TAPI / TSP Developer and Tester
My TAPI and TSPI FAQ:
http://www.yqcomputer.com/ 's_TAPI_and_TSPI_FAQ.htm
My Toto?Tools (a collection of free, mostly TAPI related tools):
http://www.yqcomputer.com/ 's_Toto_Tools.htm
TAPI development around the world (Frappr! map):
http://www.yqcomputer.com/
* Please post all messages and replies to the newsgroup so all may
* benefit from the discussion. Private mail is usually not replied to.
* This posting is provided "AS IS" with no warranties, and confers no rights.