IOPL question

IOPL question

Post by cz » Fri, 11 Mar 2005 13:26:22


Hi,

I am a happy DJGPP user for about one year now. However, I need to develop
an MSDOS program that requires IOPL 0 to run. But I found the EXE files I
created
with DJGPP is running with IOPL 3. Is this previlege level set by DPMI? Is
there
a way I can make an app to run in IOPL 0?

Thanks.
 
 
 

IOPL question

Post by DJ Delori » Fri, 11 Mar 2005 13:35:41


Yes. What OS are you running under?

 
 
 

IOPL question

Post by Charles Sa » Sun, 13 Mar 2005 07:06:40

> I need to develop an MSDOS program that requires IOPL 0 to run. Is there

Under Windows, no. Under DOS you can use either CWSDPR0.EXE or PMODETSR.EXE
to provide CPL 0 (and IOPL 0) support.