PS2/USB/Serial mouse dont work on OS2 warp 4

PS2/USB/Serial mouse dont work on OS2 warp 4

Post by K-Ma » Wed, 14 Mar 2007 11:23:07


HI,

My PS2 port does not work and for a while I was using Serial to PS2
connector to hook my mouse up to the PC running OS2, now that stopped
working all of a sudden. I tried plugging in a USB mouse hoping it
will detect it, it still doesn't. I checked the settings and it is on
autodetect on USB settings on BIOS. I do not know if I have USB
drivers installed on the system. Any ideas how can I connect a USB
mouse to this PC and if there are any drivers out there that I should
install?

OR how can I get the serial port working for the mouse again?

Thanks in advance for the help,
 
 
 

PS2/USB/Serial mouse dont work on OS2 warp 4

Post by William L. » Wed, 14 Mar 2007 13:31:03

Sir:



I am going to assume that you do not have access to any of the Warp 4
post fp15 bug fixes. Open up DD02 (Device Drivers 2) fixpack
< http://www.yqcomputer.com/ ;
by unpacking the contents. There in you'll find the base USB device
drivers and keyboard and mouse drivers for USB. These were very buggy
and will not work on many systems. But they might work on yours. Add
this to your config.sys:
BASEDEV=USBUHCD.SYS
BASEDEV=USBUHCD.SYS
BASEDEV=USBD.SYS
BASEDEV=USBHID.SYS
DEVICE=C:\OS2\BOOT\USBMOUSE.SYS
DEVICE=C:\OS2\BOOT\USBKBD.SYS
The first line is repeated as many times as you have USB controllers of
the USB 1.0 or 1.1 kind, usually one controller per two ports. Alas,
these USB controllers must be of the Intel UHCD kind, not the OHCD kind.
You must set BIOS to support legacy USB functions, in order for you to
continue to use the keyboard while booting (only apply if you are
intending to use a USB keyboard).

If your system uses OHCD controllers, then you can forget this. The
main board documentation will tell you which is used. Google on your
mainboard or vendor model if you don't have the documentation.

However, if you got the latest eCS, then it (all of USB drivers) should
already be installed on your system and you only have to remove the REM
from the lines in config.sys.

When the serial ports stops working, it is time to be ordering a new
main board, IMHO.
--
Bill
Thanks a Million!